Sony Nec AD-7173S .. ticking sounds

By yaniv
Nov 22, 2007
  1. Hi All,

    I'm a student in South Africa, and when I was in the UK visiting fam, I bought one of these Sony Nec Optiarc drives, model AD-7173s..

    When I got back to SA a few days after my purchase, I stuck in the drive, and started windows (vista) all was well... everything working perfectly.

    Then I went on the manufacturer website and got the latest firmware update, and updated the drive...

    Once that was done, I was busy messing in the pc box and accidentally removed the power cable to the sata drive....


    whenever I start the pc all I hear is ticking noises like the drive is trying to access something, even when there is no disc inside. Vista still recognises the drive and installs the drivers (I had to reinstall vista for other issues) but I can't read anything from the drive anymore.

    I have never actually used the drive yet... any ideas on how I can fix it or is it dead :(

    Thanks a lot!
  2. Daveskater

    Daveskater Banned Posts: 1,687

    Hello, yaniv, and welcome to Techspot :wave:

    Please take a moment to read the following threads to make your experience here as enjoyable as possible :)

    Message for all newcomers

    SNGX1275's Guide to making a good post/thread

    The Techspot FAQ

    If you could take a minute to fill in some of your profile information that would be helpful to all members of the forum :)
    Knowing someone's location in the world can be extremely helpful, even if you just put a country.

    Also remember to post any problems or questions that you have in the appropriate forums

    With regards to your problem, i hate to be the bearer of bad news, but it sounds like your drive is effectively dead. The optiarc drives aren't as good as some other brands out there so if it would be possible for you to get the drive back to the uk (post, maybe?) you could get your family to return it to the store and get a refund and you could buy a new drive :) Or you could simply exchange the current one, it's completely up to you :)
  3. yaniv

    yaniv TS Rookie Topic Starter

    Thank's a lot for the reply, sorry for posting incorrectly! :(

    I've had exams and things like that so I doubt the shop will take it back.. o well..

    Thank's anyway

    p.s Numbawang - classic!
  4. Daveskater

    Daveskater Banned Posts: 1,687

    it's ok, you haven't posted incorrectly, i put the forum link in for all new members as well as the other ones :)

    thanks :D i didn't have a signature and was watching mitchell and webb while on here so then a signature was born
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...