Sony Wega 55" - why is the screen turning blue????

By jimcote1
Mar 20, 2007
  1. I've had this set for 2 years - and I admit we use it alot - my wife tends to fall asleep with it on - so it almost never gets turned off -
    after 13 months the tube went and I replaced it -
    now after another 13 months a blue zone started to appear in the lower right corner of the screen - as time goes on the blue zone is getting larger and larger -
    any ideas or experience with this??? what causes it - and what's it take to fix it???
  2. halo71

    halo71 TS Rookie Posts: 1,090

    A friend of mine had the same problem. Repair shop said the convergence IC was bad and needed replaced. Whatever that is. I personally had a similiar problem with a 32" where the tube would go red every now and then. It was cheaper to buy a new TV than fix it though. Have you had a repair shop look at it?

    btw....welcome to Techspot.
  3. jimcote1

    jimcote1 TS Rookie Topic Starter

    no - at 55" I'm not going to carry it in - and they want $350 just to walk in the door -
    but that may be the only solution -
  4. TVBuyer

    TVBuyer TS Rookie

    My Sony 55XS995 Project TV has the same problem.

    I bought it at Dec 27,2004 and the problem appeared one month ago, I am talking with the dealer, repair and Sony center, like to hear from you if you have yours fixed.

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...