sound card problems :(

By nosgothhunter
Dec 7, 2005
  1. hi :) i have just brought a new computer and have tried to install a sound card but it isnt going well :(
    I got the computer today and there was no sound onit at all :( anyway this is what i have done so far

    slotted the sound card in to the pci slow. (didnt connect any wires to the 3 lil sockets on the card)
    disabled onboard sound.

    On the device manager there is a little yellow '!' by the multimedia audio controller. I have tried to reinstall the driver but it says "an error has occured during the instellation of the driver data in invalid" :(

    I have downloaded the drivers for the sound card (sound blaster live) off of there website but when i try to install them it says there is no sound blaster soundcard found on my system :/ tho i have run the cd which came with it :( can any one help??
  2. nosgothhunter

    nosgothhunter TS Rookie Topic Starter Posts: 41

    p.s it also wont let me view the sound volume :( it says no sound mixer device. dunno if that helps any
  3. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

    You have to install the drivers that are on the cd that came with the card first.The downloaded ones won't work by themselves.Try running setup off the cd and see what happens.
  4. nosgothhunter

    nosgothhunter TS Rookie Topic Starter Posts: 41

    yep tried that :( i only downloaded the ones off the net after the ones on cd didnt work :( i think the disc may be damaged or somthing because when i try to reinstall the multimedia audio controller it allways says data invalid :(
  5. dopefisher

    dopefisher TS Rookie Posts: 444

    Same Problem Here.
  6. nosgothhunter

    nosgothhunter TS Rookie Topic Starter Posts: 41

    well dont bother e mailing SB all they do is blame anti virus its got nothing to do with it :( best thing to do (though anoying) is reformat your harddrive :) fixs it just nice :) just remmber set your on board sound OFF before installing the card :)...THO!! another problem i have is the soudn card is rubbish!!! goes crackily during games and i have since found out louds of people have trouble with SB live 5.1 :( just about to buy a new one :)
  7. Triton

    Triton TS Enthusiast Posts: 82

  8. dopefisher

    dopefisher TS Rookie Posts: 444

    well, until my new x-fi platinum arrives, i have solved the prob for now.... ---better drivers than creative could ever produce, that's for sure.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...