Sound Problem with ThinkPad A31

Jul 23, 2006
  1. My IBM ThinkPad A31 CDand MP3 playback stopped working.
    No Sound, only modem and beeps.
    I've updated the RelTex AC97 drivers.
    When I tried to install SoundMax, the install unzips the software and then exits with a very informative "Driver Missing" message.
    In the Control Panner: Sounds and Audio devices Audio tab indicates no playback device, no recording device, no midi playback devices.

    Any suggestions??

  2. fastco

    fastco TS Booster Posts: 1,122

    Totally uninstall the device from the device manager, restart the computer and install with the latest drivers.
  3. WFJ

    WFJ TS Rookie Topic Starter

    The A31 has an integrated sound chipset, the device manager will not allow it to be uninstalled.
  4. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Have you looked in the BIOS under integrated devices or something of that kind ?
  5. WFJ

    WFJ TS Rookie Topic Starter

    I have looked through all of the BIOS setup options and there is nothing that gives access to the sound or modem integrated devices.
  6. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    I've had a different problem with a Thinkpad R30 where the sound would stutter at first & then disappear after a few minutes. I wouldn't get any sound before a reboot where it would once again quit after a few minutes. It turns out the driver for windows 2000 provided by IBM was very outdated & no longer supported. I had to upgrade to Windows XP to get a newer driver which (so far) works well. :(

    If nothing else works, it would seem the sound chip on your laptop is dead. It might be a good to look for another solution such as a PCMCIA sound card or an USB one but you won't be able to use the integrated speakers anymore.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...