SoundBlaster Live 24-bit digital only plays left and right speakers

By BigE
Jan 29, 2005
  1. I had a SoundBlaster Live Value card which I just upgraded to the 24-bit version for the enhaced surround sound capabilities.

    Both cards had/have the same problem. I have a cable going from the digital out jack to a mini digital 5.1 receiver. Now the receiver is a cheap Walmart brand system, but it tests fine when I hook a DVD player up to it and run the surround sound tests. All speakers check out.

    When I hook the SoundBlaster card up to it and run the Creative speaker tests under 5.1 mode, digital out only, I only get the front left and front right speakers working.

    Is there something I missing here? Could it be the cable? I am using an RCA video cable with a mono stereo convertor on one end that plugs into the sound card. My understanding was that with a digital signal that is all you need, and it will either be there and working or not at all.

    Any help would be greatly appreciated.

  2. timmyham

    timmyham TS Rookie


    Same problem, any solutions?
  3. shadow_29

    shadow_29 TS Rookie Posts: 211

    well it might be because of the source sound is in stereo and not 5.1,play a dvd movie to check if the output is in 5.1 or stereo.
  4. gospelmidi

    gospelmidi TS Rookie Posts: 22

    You have to turn on the 5.1 option.,Case=obj(5805)

    1. Insert the install CD into the CD-ROM drive.

    2. You will notice that there are a number of applications on each of the CDs. For example, the installation menu from the Sound Blaster Live! Value CD contains the following sections:
    Creative Sound Blaster Live! Experience
    Creative Keytar
    Creative Rhythmania
    Creative Sound Blaster Live! Value
    Prody Parrot

    3. To install or reinstall any of these, just tick or untick the respective tickbox.

    The core software, which is necessary in order for your card to work, is contained in the section called Creative Sound Blaster Live!

    Sound only from the Digital Out on the Sound Blaster Live!

    If there is sound only from the digital output on your Sound Blaster Live! card, then please do the following:

    1. Click Start and go to Programs - Creative - Sound Blaster Live! , then click Surroundmixer.

    2. Click the red plus sign above the Master Volume Control.

    3. Un-tick the option 'Digital Output Only'.

    SoundBlaster Live! - Imbalanced sound playback in 4 speaker mode

    This happens when an effect selected from the Environmental Audio tab, is called upon in another media option.

    To remove any Environmental Audio effects try the following:

    Click Start and go to Programs, then Creative. Click Creative Launcher
    From the taskbar select Playcenter and open Environmental effects
    Set to 'No Effects'
    Alternatively from the Creative Launcher select Audio HQ - Speaker - Effects - Environmental effects, and select 'No Effects'.

    Attached Files:

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...