TechSpot

Spyware or a rootkit?

By kodiak
Nov 18, 2007
  1. Hi.

    I have this problem. Wen i log on normally on my windows XP SP2 some files of my antivirus disapear so it stops working. I can boot on safe mode (i was unable to do this but i solve with SafeBootKeyRepair.exe) and i install the antivirus and wen i do a scan it says it is clean. I also run ewido with the latest definitions and it does not detect anything. Wen i boot in normal mode, not only the ewido does not work (some files disappear) so does not work the av.

    Here is my hijackthis log


    Can you help me?

    By the way, this problem is at my job and it is not connected to the internet and it is not connected to the job network. It was infected with my portable disk. My computer at home is Ok.


    Best regards,


    Kodiak
     
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Your system is infected with malware.

    Very Important: Before deciding whether you should clean or reformat your system, go and read this thread HERE and decide what it is you want to do.

    If after reading the above, you wish to clean your system, do the following.

    Go and read the Viruses/Spyware/Malware, preliminary removal instructions. Follow all the instructions exactly.

    Post fresh HJT, AVG Antispyware and Combofix logs as Attachments into this thread, only after doing the above.

    Also, let me know the results of the Panda Antirootkit scan.

    Regards Howard :wave: :wave:

    This thread is for the use of kodiak only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  3. kodiak

    kodiak TS Rookie Topic Starter

    Hi.

    First of all thanks for your answer.

    I have done almost everything you said to do in the posts. The only thing i didn't do was the online scanner since the computer isn't connected to the internet.

    Best regards,


    Kodiak
     
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    What were the results of the Panda Antirootkit scan?

    Click start/run and type services.msc into the run box and press the enter key.

    When the window appears, maximise it. Double click on the following services(if there) and select stop if they are running. Set the startup type to disabled. Click apply/ok for each service you disable.

    Windows ln Manager

    Close the services window.

    Open notepad and copy/paste the text in the code box below into it:
    NOTE* make sure to only highlight and copy what is inside the quote box nothing out side of it.
    Also ..

    Pay particular attention to this :-

    Make sure the word File:: is on the first line of the text file you save (no blank line above it, & no space in front of it)
    Code:


    Save this as CFScript.txt

    Then drag the CFScript.txt into ComboFix.exe as you see in the screenshot below.

    [​IMG]

    This will start ComboFix again. After reboot, (in case it asks to reboot), post the contents of Combofix.txt in your next reply together with a fresh HJT log.

    Regards Howard :)

    This thread is for the use of kodiak only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  5. kodiak

    kodiak TS Rookie Topic Starter

    Ok.
    I will do that tomorrow at work.

    Here are the panda files.

    Best regards,

    Kodiak
     

    Attached Files:

  6. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    You should have Panda Antirootkit fix all those files as they are definitely nasty.

    Regards Howard :)

    This thread is for the use of kodiak only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  7. kodiak

    kodiak TS Rookie Topic Starter

    Ho Chi Min

    Hi.
    Wen i was going to run the panda rootkit it said that there was no rootkit found. I was the able to install the antivirus and wen I run it, I saw there were some files in quarantine derived from combofix. I believe that combofix fixed the problem. Although this is ok I realized than wen I run Windows Media Player, it gives this message "An internal error occurred". Media player does not work. The same happens to the search assistant in explorer.exe. Wen i try to search the files, it gives me this image:
    [​IMG]
    Best regards,


    Kodiak
     
  8. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    I`m still waiting for you to attach fresh Combofix and HJT logs as I requested in post#4.

    Regards Howard :)

    This thread is for the use of kodiak only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  9. kodiak

    kodiak TS Rookie Topic Starter

    Hi.
    Sorry but I haven't realized that i didn't answer your question.

    Here are the new logs.

    By the way. I believe that wen i ran the first time combofix.exe it deleted the rootkit. On the other end i believe it was the reason why my media player, search assistent, Help and Suport and the opening page in services.msc stopped ti work properly.
    [​IMG]


    Best regards,


    Kodiak
     
  10. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    You might want to copy and paste these instructions into a notepad file. Then you can have the file open in safe mode, so you can follow the instructions easier.

    Boot into safe mode, under your normal user name(NOT THE ADMINISTRATOR ACCOUNT). See how HERE.

    In Windows Explorer, turn on "Show all files and folders, including hidden and system". See how HERE.

    Click start/run and type services.msc into the run box and press the enter key.

    When the window appears, maximise it. Double click on the following services(if there) and select stop if they are running. Set the startup type to disabled. Click apply/ok for each service you disable.

    Windows ln Manager

    Close the services window.

    Open your task manager, by holding down the ctrl and alt keys and pressing the delete key.

    Click on the processes tab and end process for(if there).

    lnhost.exe
    RavMon.exe

    Close task manager.

    Run HJT with no other programmes open(except notepad). Click the scan button. Have HJT fix the following, by placing a tick in the little box next to(if there).

    O4 - HKLM\..\RunServices: [Windows ln Manager] lnhost.exe

    O4 - Global Startup: AutorunsDisabled

    Click on the fix checked button.

    Close HJT.

    Locate and delete the following bold files and/or folders(if there).

    C:\WINDOWS\system32\Chip.dll
    C:\WINDOWS\system32\RavMon.exe
    lnhost.exe<Search your system for this file and delete all instances found.

    Click start/run and type regedit into the run box and hit the enter key.

    Navigate to the following regkeys and delete the bold portions(if there).

    HKEY_LOCAL_MACHINE\software\microsoft\windows\currentversion\runservices\Windows ln Manager

    HKEY_CURRENT_USER\software\microsoft\windows\currentversion\explorer\m ountpoints2\{21a7c33c-7fa8-11db-9f7b-000ffe1fbb9d}

    HKEY_CURRENT_USER\software\microsoft\windows\currentversion\explorer\m ountpoints2\{55605fd7-d6c4-11db-9fd8-000ffe1fbb9d}

    HKEY_CURRENT_USER\software\microsoft\windows\currentversion\explorer\m ountpoints2\{85994da8-2ba9-11dc-a036-000ffe1fbb9d}

    HKEY_CURRENT_USER\software\microsoft\windows\currentversion\explorer\m ountpoints2\{e2e9f7ca-f94d-11db-9ffc-000ffe1fbb9d}

    Close regedit.

    Reboot into normal mode and rehide your protected OS files.

    Post fresh HJT and Combofix logs.

    Regards Howard :)

    This thread is for the use of kodiak only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  11. kodiak

    kodiak TS Rookie Topic Starter

    Hi.

    Here is what you asked.


    Best regards,


    Kodiak
     
  12. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    All clean.

    Click start/run and type combofix /u into the run box and hit the enter key. That should delete Combofix and all it`s folders etc.

    Turn off system restore.(XP/ME only) See how HERE.

    Now, turn system restore back on. This will have deleted all your old restore points and any nasties that are in them. It will also have created a new, clean restore point.


    If you have any further virus/spyware problems, please post in this thread.

    Regards Howard :)

    This thread is for the use of kodiak only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  13. kodiak

    kodiak TS Rookie Topic Starter

    Hi.

    Everything OK.


    Thanks.

    Best Regards,


    Kodiak
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...