TechSpot

Start Menu/All Program Not Showing (empty)

By Kazam_Oiler
May 26, 2006
  1. Hi, I have a big problem and I dont know how fix it. I have searched and searched and yet no solution to my problem.

    Today for no reason, I turned on my computer and clicked the start -> All Programs and nothing is appearing. I switched it to classic mode and it said the folder "Programs" is empty. And yet the files are still there.
    "C:\Documents and Settings\All Users\Start Menu\Programs"

    -I tried running the Check Disk Scan but it wasnt working.
    -I tried this solution http://windowsxp.mvps.org/AllPrograms.htm
    -I tried restoring my computer to prevoius dates but it wasnt successful.

    I dont want to reformat my computer because it is a pain. Thank you for any suggestions.
     
  2. Peddant

    Peddant TS Rookie Posts: 1,644

    You may have already tried these,but anyway -

    Start>Run>Regedit>ok
    Now navigate to the following keys:-
    HKEY CURRENT USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    Set Start Menu value to "%USERPROFILE%\Start Menu"

    HKEY LOCAL MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    Set Common Start Menu value to "%ALLUSERSPROFILE%\Start Menu"

    OR

    Copy and paste the following reg fix into notepad,then save it with a .reg extension,then double click on it.

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoStartMenuMorePrograms"=dword:00000000

    Further reading HERE
     
  3. Kazam_Oiler

    Kazam_Oiler TS Rookie Topic Starter

    I tried that, when i go into the registry

    Set Start Menu value to "%USERPROFILE%\Start Menu"
    Set Common Start Menu value to "%ALLUSERSPROFILE%\Start Menu"

    These values are already like that. But however I just retyped it in again, but with no success.
     
  4. Peddant

    Peddant TS Rookie Posts: 1,644

    How about the reg fix ?

    Another idea HERE Quote -

    "*Somehow* - dramatic pause - C:\Documents and Settings\All Users\Start
    Menu\Programs was marked "Hidden." This prevented their display.
    Unchecking "Hidden" under Properties resulted in their (immediate)
    display."

    Also from HERE -

    "right click start/explore all users
    this opens the "documents&settings" folder where all this information is
    stored.
    From there you should be able to find the "start Menu" under one of the
    users and copy it to your user as well as "All users".Take a good look at
    how its setup and you will be able to copy.

    Do not add a user..do not delete a user..that is done under control
    panel/user accounts."
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.