Static IP On A Wireless Connection?

By Jasio-
Mar 5, 2006
Topic Status:
Not open for further replies.
  1. I have had a wireless connection for about 2 years now.. and i've been playing WarCraft III for about that long also.. To host games you have to have ports 6112-6119 open, and have a static IP.. before i had my computer reformatted, this was never a problem. When i got the computer back and tried playing, i was unable to host, but my ports were still forwarded. I tried switching this computer to Static IP (same as my router) but it will not let me. I wanted to know how it was possible before, or how I did it.. cause i can't seem to get it to work
  2. Jimbo420

    Jimbo420 Newcomer, in training Posts: 484

    How did you go about putting the comptuer on a static address like so that it won't be changed by the router?
  3. Jasio-

    Jasio- Newcomer, in training Topic Starter Posts: 95

    I guess i didn't, i installed it on my computer (before reformatting) and was able to host then and there.. but its only become a problem now ..
  4. Jimbo420

    Jimbo420 Newcomer, in training Posts: 484

    Installed what? There isn't sofware that you need just have to go into your network properties and hard set your IP address and DNS servers that your router is using and then you will be fine.
  5. Jasio-

    Jasio- Newcomer, in training Topic Starter Posts: 95

    Installed WarCraft..

    When i tried setting this computer to the same IP as my router (other computer) it told me that the IP was already in use, and to find another IP
  6. Jimbo420

    Jimbo420 Newcomer, in training Posts: 484

    You can't have the IP address set to the same as the router. You said that you still have the ports forwarded what address to you have them forwarded to? That is what you should set your IP address to.

    Most of the time your router will be something like 192.168.1.1 and the computer would be something like 192.168.1.101. Then as long as you have valid DNS servers in there it should work perfectly.
  7. Jasio-

    Jasio- Newcomer, in training Topic Starter Posts: 95

    Ok so..

    i have 2 computers, one is set for .100, the other (wireless) .101. Does .100 need to even be a static IP, or can it be whatever, aslong as the router is forwarded to .101?
  8. Jimbo420

    Jimbo420 Newcomer, in training Posts: 484

    I have found that my router like to change my internet IP addresses from time to time. Therefore since I have some ports forward to my computer for games I hard set it to 100 (number doesn't really matter whatever you address you have the ports forwarded to) and then I have my webserver on 101 since that also had important ports forwarded to it. Then after that any other computer that don't have ports forwarded to them for important things and be left on DHCP, and can really have any address.
  9. Jasio-

    Jasio- Newcomer, in training Topic Starter Posts: 95

    Well, heres what i did, i went into my Router Configuration (typed ip into adress bar) and made the ports forwarded to .101, which is my Wireless's Static IP.. But then when i went to host i was still unable to.. so i guess i still need help on this.. maybe ive done something wrong :rolleyes:
  10. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    Do you have the relevant ports open in your software firewall?
  11. Jimbo420

    Jimbo420 Newcomer, in training Posts: 484

    Is 101 the address for the computer that you are trying to use to host these games?
     
  12. Jasio-

    Jasio- Newcomer, in training Topic Starter Posts: 95

    Yes, 192.168.1.101 is the adress im forwarding to, and is also the hosting computers IP adress.. When i go to host nothing has changed (people cannot join) So im not sure what to do.. has anyone had a similar problem?
  13. Jimbo420

    Jimbo420 Newcomer, in training Posts: 484

    It is probably something like Nodsu said you probably have a software firewall that is on there blocking the ports. If you are using Windows XP I know you will need to turn off the Windows Firewall as it is on by default and blocked me from playing games like Diablo 2 when I first got Windows XP.
  14. Jasio-

    Jasio- Newcomer, in training Topic Starter Posts: 95

    Wow.. i cant believe i forgot that ! thats the first thing i did when i was originally playing WC3, someone told me you have to shut down Windows Firewall for it to work (ofcourse, i had to port forward later) but im going to try that ty..
  15. Jasio-

    Jasio- Newcomer, in training Topic Starter Posts: 95

    Yes, it worked.. finally. Thank you all for your help.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.