TechSpot

still unable to create network at home

By Eddie_42
Jul 24, 2006
  1. Hello,

    Ive posted about this before but nothing worked so i thought id try again.

    I have a laptop and a PC. They are both running XP with all the lastest updates and firewall turned off. I am runngin AVG antivirus 7.1.

    The two computers are able to access the internet fine. I can even have a chat message with myself.I can enter in the IP from either computer and get a successful ping. however when i try to access the other computer i get an error that says "network path not found".

    The two computers used to be linked, I dumped all my files from my PC to the laptop and reformatted my PC, nasty trojan. after the format i can no longer see the laptop and it cannot see the PC.

    My IP addresses are weird too. The to computers are not using the same gateway even though they are connected into the same router.

    pc:
    ip address: xx.xxx.54.204
    gateway: xx.xxx.52.1

    laptop:
    ip address: xx.xxx.58.47
    gateway: xx.xxx.56.1

    I have tried numerous times to re-install the network using the wizard. I have moved and reseated my network card in my PC. And i have reinstalled the drivers for both network cards in the respective computers.

    Please help. I just want my files back.

    Thanks,
    Eddie_42
     
  2. fastco

    fastco TS Rookie Posts: 1,511

  3. Eddie_42

    Eddie_42 TS Rookie Topic Starter Posts: 213

    i used those...didnt work
     
  4. jobeard

    jobeard TS Ambassador Posts: 13,474   +329

    to be blunt, you have a routing nightmare; different gateways and subnets.
    life gets simple IF:
    a) you have one subnet, eg 192.168.0.X where 254 < X > 0
    b) you have a simple netmask eg 255.255.255.0
    you hide the suggesting a public IP ( & maybe associated with a domain)

    put your ISP interface into a router WAN and the systems into the LAN side,
    enable DHCP and enjoy :)
     
  5. Eddie_42

    Eddie_42 TS Rookie Topic Starter Posts: 213

    the subnet masks are the same on both computers:
    255.255.252.0

    the first and second octant of the ip and the gateways match on both computers as well. The variation is in the 3rd and 4th octants:

    eg:

    #1 ip: xx.yyy.58.47 gateway: xx.yyy.56.1
    #2 ip: xx.yyy.54.204 gateway: xx.yyy.52.1

    I do have the incoming cable connection plugged into the WAN port and the two computers are plugged into the 4th and 3rd jacks of the router. its a linksys if that helps.
     
  6. Eddie_42

    Eddie_42 TS Rookie Topic Starter Posts: 213

    Sorry,

    I lied in my last post. The incoming signal from the cable modem was plugged into the "uplink" jack in my router. I have moved it to the WAN jack. I restarted both computers and ran the network wizard again.

    Unfortunatly this did not fix the problem!!!

    however the IP's look much better and only vary in the 4th octant which they should.

    #1 xxx.yyy.z.100
    #2 xxx.yyy.z.101

    I still cannot see the shared files from either computer. I can successfully PING the computers. But i still get a "network path not found" error
     
  7. jobeard

    jobeard TS Ambassador Posts: 13,474   +329

    better indeed! :) ping says your routing is correct so the only thing left is the
    file sharing.

    both systems need to enable print/file sharing in the firewall (ie ports 139/445)
    your GUEST account will be used for accessing, even if it is disabled.
     
  8. Eddie_42

    Eddie_42 TS Rookie Topic Starter Posts: 213

    both of those ports are already on.

    I can still ping the computers however with the firewall on or off i can not get linked to the other computer.

    why must computers be difficult??
     
  9. Samstoned

    Samstoned TechSpot Paladin Posts: 2,582

    router setup
    192.168.1.1 default lan gateway
    disable dhcp in router
    set nic static
    192.168.1.10
    255.255.255.0 <----bet the routers set to this
    192.168.1.1 <---default gateway


    in router get the wan dns ip numbers 2 of them in most cases
    put them in below
    for 2nd nic make 192.168.1.11
    use the rest above
    go to your network and see if you can see the 2 machines
    I hope both are on same workgroup makes it easyer
    for joebeard below
    2) Name Each Workgroup (or Domain) Correctly
    Each Windows computer belongs either to a workgroup or a domain. Home networks and other small LANs utilize workgroups, whereas larger business networks operate with domains. Whenever feasible, ensure all computers on a workgroup LAN have the same workgroup name. While sharing files between computers belonging to different workgroups is possible, it is also more difficult and error-prone. Similarly, in Windows domain networking, ensure each computer is set to join the correct named domain.
     
  10. jobeard

    jobeard TS Ambassador Posts: 13,474   +329

    the workgroup names MUST be identical
    dhcp will work just fine too, as it just sets IP addresses that you might set
    for yourself.

    N.B:- if you can PING from a->b and b->a, then the IP settings are just fine :)
    if you can ping your ISP by name, then the routing and DNS lookup are fine too :) :)
     
  11. Eddie_42

    Eddie_42 TS Rookie Topic Starter Posts: 213

    ok...i went into the router and everything looked fine.

    I re-state....both computers can use the internet

    i can ping a->b and b->a

    both are on the same work group.

    everything worked until i formated and reinstalled windows...i didnt change any settings in the other computer or in the router.
     
     
  12. jobeard

    jobeard TS Ambassador Posts: 13,474   +329

    then your network settings are just fine -- leave them alone.
    the problem is file sharing itself.
     
  13. Eddie_42

    Eddie_42 TS Rookie Topic Starter Posts: 213

    suggestions????
     
  14. Rick

    Rick TechSpot Staff Posts: 6,305   +52 Staff Member

    What happens if you ping your other computer's hostname? "network path not found" makes me think there might be an issue resolving your hostname(s).

    If you don't know your computer's hostname, you can go to Start > Run and type in cmd. Then type hostname as the command. It will list your computer's hostname.

    Let's say your hostname is 'workplease'

    Now from the other computer, type ping workplease in the command terminal. Does it resolve? If this doesn't work, trying renaming your computer, restart and rename it to your previous name again.

    If it does resolve, open your network browser and type \\workplease into the address bar. What kind of error appears (if any?).

    If you are not able to connect still - out of curiosity - are you able to reverse the situation and access the opposite computer from the one you are trying to connect to now? Set up a share... Just to see if it works.
     
  15. jobeard

    jobeard TS Ambassador Posts: 13,474   +329

    there's only three ways to make PING $HOST-BY-NAME
    1. add the name to your HOSTS file (windows/system32/drivers/etc/hosts)
    2. add the name to your LMHOSTS (windows/system32/drivers/etc/lmhosts.sam)
    3. make an entry in the DNS system
    (3) requires you to be the operator/owner of the DNS so this is least likely
    and (1-2) require a static IP address (or MAC filtering to get DHCP to force a mapping)
     
  16. jobeard

    jobeard TS Ambassador Posts: 13,474   +329

  17. Eddie_42

    Eddie_42 TS Rookie Topic Starter Posts: 213

    ping "hostname" didnt work, nor did it work when i changed the names of the computers.

    Im useing XP home so the "simple file sharing" is always on. You can only change that in XP pro.

    the router can see the computers and there names. When I log into the router and pull up a list of computers using the DHCP it brings up both computers with there names, IP's, and MAC adress.
     
  18. Samstoned

    Samstoned TechSpot Paladin Posts: 2,582

    look for a user with long letter number combination
    this will be in users and groups and or under shared folders or security
    sounds like the old admin permissions still in force
    I find deleting this account helps
    my admin is part of administration and network groups
    I don't use the default user name admin this is changed for security
    the name is an account name for group administators

    keep playing around with the permissions and security settings you will find the unlock
     
  19. Rick

    Rick TechSpot Staff Posts: 6,305   +52 Staff Member

    There's a 4th way which was not mentioned. NetBIOS over TCP/IP broadcasts your hostname without the need of HOSTS, DNS server or even LMHOSTS (although it ca use this as well, as an additional method if you prefer).

    NetBIOS over TCP/IP is enabled by default on Windows XP installs, but at the mercy of the router's support for NetBIOS. But, I don't think I've ever seen an issue resolving hostnames due to a router (With Windows, at least). Probably because most Home/SOHO equipment supports this.
    This tells me your router does support it. And I happen to think it is really strange that you cannot ping the other computer's hostname.

    What I would like you to try next is open up your network browser and type \\IPADDRESS, IPADDRESS being the IP of the computer you're trying to connect to. What happens? We know you can ping IPs, but have you tried this?

    You should get a 'Permission denied' error or something along those lines, not a 'Network path not found' error. If you do see some other error message (if any at all), then this is some progress. The 'Network path not found" error is usually a result of a shortcut (possibly one that uses a hostname, like \\computer\shared_folder), but it cannot be found. Being unable to resolve hostnames could be a potential reason for this. Using the IP address directly should help us determine if this could be the problem or not.
     
  20. Rick

    Rick TechSpot Staff Posts: 6,305   +52 Staff Member


    Network path not found

    I won't rule anything out, but the error Eddie_42 described would suggest otherwise.
     
  21. jobeard

    jobeard TS Ambassador Posts: 13,474   +329

    Today, use of multiple protocols is highly discouraged and usually unnecessary.
    The routing is done via DNS lookup (port53) to resolve into a ip-address.
    Windows hooks the TCP/IP stack to enable LMHOST transparent to the application.

    All the firewall flitering of ports 135-139 are to defeat NetBIOS access.
     
  22. jobeard

    jobeard TS Ambassador Posts: 13,474   +329

    missing entry in HOST file. TCP does not use the MS name from the CP-System.
    of course! but that does not say you have routing by name --
    routing is NOT associated with the 'router' per say
    even though is has that name. If you want to SEE the routing, issue
    netstat -r
    this is a table of IP address and where requests will be sent by address.
    DNS is used to convert name->address.

    your problem is NOT networking, but rather permission, firewalls, or sharing config. stop wasting your time fighting with the network.
     
  23. Samstoned

    Samstoned TechSpot Paladin Posts: 2,582

    try creating a same user for network on both machines same password
    xp home needs both machines to have this
    then try logging in with this
    you may have to go to safty mode to fix security settings
    to allow access and enable pass prompt
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.