Strange intermittent partial disconnect/time out issue

By Kylezo
Apr 25, 2009
  1. Hi all, I have been having a strange problem with my computer: usually only when I first start up/connect, but sometimes intermittently, I have this wierd ping time out error. For example, I am connected in an IRC server, a Ventrilo server (voice chat) and a game server (World of Warcraft, Diablo II, etc). Suddenly I will get disconnected from Vent and be unable to browse webpages, but still in IRC or the games. So using TCP Optimizer, I run the largest MTU utility, and my connection is fine on the 750 byte packet, but not the 40 byte packet. In a few minutes, this condition seems to just go away by itself. In fact, just now, I ran the test and timed out on the 750, but I was still connected in Vent. I ran the test again and it went through (it usually takes more like 5 + tries or several minutes of downtime). Tapping my computers wireless button on and off seems to 'stabilize' my connection, but I don't want to disconnect from everything else I am already connected to every time I get on my laptop.

    How do I go about diagnosing this issue? I'm not sure where to look.

    In the event log, nothing shows up, except this error once in a while:

    Event Type: Warning
    Event Source: BROWSER
    Event Category: None
    Event ID: 8021
    Date: 4/24/2009
    Time: 2:23:02 AM
    User: N/A
    Computer: 1337B00K
    The browser was unable to retrieve a list of servers from the browser master \\KATHY on the network \Device\NetBT_Tcpip_{0597287D-4268-4CD5-85C6-A2C6E2883833}. The data is the error code.

    Not sure if these are even related, just thought they might help.

    Thanks in advance!
  2. jobeard

    jobeard TS Ambassador Posts: 9,145   +597

    no, that event has nothing to do with connectivity beyond your router --
    Browser events are localized to your LAN devices only.

    It's far more likely that your Modem, Router and/or network adapters need firmware or
    diver updates.

    Personally, I disdain large MTUs and the use of TCP Optimizer.
    On the MTUs, the network path between you and any given server will adapt to the
    COMMON mtu to avoid fragmentation anyway.
  3. Kylezo

    Kylezo TS Rookie Topic Starter

    My MTU is set to 1500 because I use PPPoE. Is that wrong?

    My desktop does not have this problem, so it's probably not my gateway... besides, no new firmware is avaialbe for it =P

    I had the feeling it was a driver issue, but I think I have the latest driver for my laptops wireless card. I'll double check.

  4. jobeard

    jobeard TS Ambassador Posts: 9,145   +597

    PPPoE has an extra 8 byte header, so the MTU should be 1492 :)
  5. Kylezo

    Kylezo TS Rookie Topic Starter

    By the way, afaik TCP optimizer is perfectly safe and has always stabilized and increased my speeds on all my other systems...not to mention that in this case I am only using it for the MTU test to find largest unfragmented packets.

    edit: sorry, forgot to mention, I meant 1492, not 1500.
  6. jobeard

    jobeard TS Ambassador Posts: 9,145   +597

    yes it is safe -- just not always effective
  7. Kylezo

    Kylezo TS Rookie Topic Starter

    Anyways, back to the subject at hand...

    any other thoughts? maybe I should use old drivers? I don't know how to go about troubleshooting this...any ideas of what I should do next time it happens to get more info?
  8. Kylezo

    Kylezo TS Rookie Topic Starter

    hi, bump please :D
  9. Kylezo

    Kylezo TS Rookie Topic Starter

    Today, I couldn't connect to Vent, or even to my routers' setup page by putting my router IP address in the address bar. But I could connect to IRC fine. I timed out sending large packets again, and had no problem sending ~40 byte packets. So there you go.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...