Strange problem with Directx 9.0c installation

By Menidar
Jun 6, 2005
  1. Hi guys, first time caller, long time listener :cool:

    I've encountered a very strange problem with my directx9.0c installation. When I try to install it, it sends me directly to the "Installation completed" screen, without having copied any files to my computer.

    This is what dxdiag is looking like:

    OS: Windows XP professional (5.1, Build 2600)
    Processor: AMD Athlon(tm) Processor, MMX, 3DNow, ~1.0GHz
    Memory: 768 RAM
    DirectX Version: DirectX9.0b (4.09.0000.0903)

    I run a ATI ALL-IN-WONDER 9800 series with the latest CATALYST drivers.

    Any help on my strange problem would be very appreciated.

    Thank you
  2. JustinPS

    JustinPS TS Rookie Posts: 28

    The download may be bad...did you try downloading it from another source?

  3. Menidar

    Menidar TS Rookie Topic Starter

    I've downloaded it from microsoft directly, and 3 other websites, I tried installing it from SWAT4 and from the redistrubutable version found on this site, always the same result.
  4. Menidar

    Menidar TS Rookie Topic Starter

    I also get this in the notes:

    The file qasf.dll is an old version, which could cause problems.
    You should reinstall DirectX to get the latest version. (lol)
  5. Menidar

    Menidar TS Rookie Topic Starter


    Does anyone know how I could replace this qasf.dll file?
  6. mailpup

    mailpup TS Special Forces Posts: 6,964   +355

    I don't know what version it is but you can get that file at:

    Instead of deleting the existing version, rename it, then replace it with the downloaded one. That way you can always go back the original if necessary.
  7. Menidar

    Menidar TS Rookie Topic Starter

    I tried replacing it, but the file always goes back to the old one :S
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...