TechSpot

Surreal GNOME Problem

By MYOB
Nov 18, 2004
Topic Status:
Not open for further replies.
  1. I'm running Debian Sid here, with GNOME 2.8 from experimental. When I start GNOME (through KDM/GDM/XDM/Whatever), I get the splashscreen, then a gnome-terminal. I eventually figured out I had to start metacity manually from this terminal. If I do that, GNOME eventually starts up, 3 to 4 minutes later, and I can kill the terminal - metacity stays running.

    Is there any way around this?
     
  2. Nodsu

    Nodsu TS Rookie Posts: 9,431

    In true Gnome way there is a wrapper inside a wrapper inside a wrapper to run the window manager and any of these can be broken..

    First thing you should try is to run the Gnome configuration editor and check under
    /desktop/gnome/applications/window_manager/default entry to see what window manager it is set to run by default.
     
  3. MYOB

    MYOB TS Rookie Topic Starter Posts: 527

    Default is blank, current is /usr/bin/gnome-terminal.wrapper

    Which explains why it launches Terminal at startup then...

    However, gconf-editor doesn't want to let me set a default or change the current one as a normal user, and as root they're both blank.
     
  4. MYOB

    MYOB TS Rookie Topic Starter Posts: 527

    By "doesn't let me", I mean it acts as if they're saved but if I reopen gconf-editor, they're not.
     
  5. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Take a look in /etc/gconf/2/paths file

    This lists the places gconf configurations are loaded from. From these you can check/change default configurations. You ought to have some "readwrite" locations there where lamers could write their settings.
     
  6. MYOB

    MYOB TS Rookie Topic Starter Posts: 527

    Tried changing the settings manually in $HOME./gconf/desktop/gnome/applications/window_manager - this time a change to default holds but current changes back to gnome-terminal.wrapper as soon a gconfd-2 restarts

    On running gnome-session from a safemode xterm, I get the error "WARNING: No window manager could be found". This is an error from the gnome-wm script I think. On checking that, the script variable DEFWM wasn't set. Setting this by hand to /usr/bin/metacity had the same result - nothing, except the addition of a warning from a crashing gconfd-2...

    I can hear XFCE4 calling me in the distance at this stage... I want a GTK2 DE, but GNOME seems to be a total *****
     
  7. Nodsu

    Nodsu TS Rookie Posts: 9,431

    I think the word "experimental" says it all..

    Check from which configuration file that terminal wrapper is taken from and then manually edit it to be the metacity exacutable.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.