svchost.exe Application Error

By dafamily
Sep 20, 2006
  1. Sometimes whenever I boot up my computer, I get this problem:

    svchost.exe - Application Error

    "The instruction at "0x7c91D5f8" referenced memory at "0x00000010". The memory could not be "read".

    And after that whenever I play something that has sound, it won't play it, or it won't play it without sound, or, it saids I have a "Bad Sound Driver".

    This problem occurs every once in a while, sometimes it happens and sometimes it doesn't. Does anybody know how to fix this???
  2. Rik

    Rik Banned Posts: 3,814

    Without knowing any information about your pc its imopssible to diagnose your problem!!!
  3. Peddant

    Peddant TS Rookie Posts: 1,446

    There is a good page HERE Read it for the details.

    A summary -

    Svchost.exe is a host process for other network related processes.
    One of which is bringing down the whole shiboodle.

    The fixes that worked for ppl,

    1."I just resolved my issue by turning off automatic updates, reboot, then manually going to
    windows updates and installing the updates, turing on automatic updates, reboot."


    2."When I fully uninstalled HP printer software,then ran CCleaner and reinstalled only
    a limited driver (not the whole crappy HP software suite), things were fine."

    3.Disable the SENS service.It "Tracks system events such as Windows logon, network, and power events.
    Notifies COM+ Events. Windows Automatic updates and syncing of mobile devices won`t work.


    4.Disable Windows image acquisition service (WIA).Related to scanners and cameras.
    Check for updates to scanner/printer drivers.Particularly HP drivers.


    5."Tried lots of things including changing sound card and network cards.The problem has
    stopped.Don`t know what cured it"
  4. dafamily

    dafamily TS Rookie Topic Starter

    I'm going to start with the first one and see how it goes, so how do you turn off the automatic updates?
  5. Peddant

    Peddant TS Rookie Posts: 1,446

    Control Panel/Performance and Maintenance/System/Automatic Updates/ select turn off updates.

    All those ideas are easily googleable.

    If you have any HP equipment/drivers,that`s the most likely one.
  6. dafamily

    dafamily TS Rookie Topic Starter

    Mine isn't selectable, it won't let me select to turn off updates
  7. Peddant

    Peddant TS Rookie Posts: 1,446

    Are you the administrator of the computer ?

    The panel should look something like this

  8. dafamily

    dafamily TS Rookie Topic Starter

    yeah man I'm the adminstrator of the computer and mine isn't selectable???
  9. Peddant

    Peddant TS Rookie Posts: 1,446

    You could try turning off the Automatic Updates service -

    Control Panel/Administrative Tools/Services/right click Automatic Updates/disable.

    As mentioned earlier disabling the SENS service also stops Automatic updates,indirectly.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...