System restore problem

By CmdrData
Feb 20, 2008
  1. I recently posted about a long boot problem, and now that I've got it resolved, I tried saving my current OS state using system restore. I clicked My computer and system restore tab, and got a "Run a DLL as an App has encountered a problem and needs to close. We are sorry for the inconvenience.". Details says: AppName rundll32.exe, modName srrstr.dll has a problem. Can you help? Thanks.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Option #1


    Go to:


    If a "DisableSR" value doesn't exist, go to the Edit menu, select New, DWORD value, and create the value.
    Set the value to 1 to disable System Restore or 0 to enable System Restore.

    Option #2

    1. In My Computer, click the Tools menu -> Folder Options.
    2. On the View tab, make sure to check the option "Hide extensions for known file types".
    3. Click OK.
    4. Click the Start menu -> Run. Type: " %windir%\inf " (Without quotation marks) in the Open field. Click OK.
    5. Locate and select the file " sr.inf ". Right-click it and then click Install.

    Option #3
    From the reliable Kellys Korner site
  3. jobeard

    jobeard TS Ambassador Posts: 9,158   +598

    RunDLL has the error, not System Restore.

    boot into Safe Mode and run SFC /SCANNOW to fix permissions
  4. CmdrData

    CmdrData TS Rookie Topic Starter

    All, I've tried your suggestions to no avail. My registry already has disableSR = 0, and I've gone into safe mode and ran both "chkdsk -F", as well as "sfc /scannow". Still has the same problem. BTW, Dr Watson also reported an error after I close the runDLL error window.
  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...