TechSpot

System32\config file missing or corrupt

By xaghra
Feb 16, 2005
Topic Status:
Not open for further replies.
  1. Hi,
    My husband has a problem on his computer in that a message appears on bootup stating the following.
    "Windows could not start because the following file is missing or corrupt.
    windows\system323\config\system"
    You can attempt to repair this file by starting windows setup using the original CD ROM.
    This he has done, put cd in and told to select R at the first screen to start repair,so that recovery console will work.
    Unfortunately it goes through its program but no repair takes place. Can anyone help please.

    His OS is XP Home
  2. sbitech

    sbitech TS Rookie

    Same problem

    Hi Xaghra,

    Hope your problem is solved already. If not, it might help that I have the same problem.. anyone who can help?

    Same file missing...
    Start from Windows XP cd-rom...
    Select r at first screen...
    But... seems like my keyboard is no longer recognized, as the program doesn't start/proceed..

    Anyone have any idea how to solve it? Keyboard works up until this screen so should be fine, I'd say..

    Much appreciated,

    Stefan


  3. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

    Don't know if that works, but try to boot in Safe Mode.
    In windows\system32\config\ you will find 2 files named:
    system and
    system.alt

    Make a new directory, e.g. syssafe (anywhere you can find it again)
    Copy both those system files in there.
    Try to rename the file system to system-old and rename system.alt to system
    Then try a reboot.
  4. sbitech

    sbitech TS Rookie

    Thanks, but I can't get that far..

    Tried safe mode, safe mode with command promt, even last known good config, which all give the same message (file missing or corrupt, \windows\system32\conifg\system)

    Also, when following the procedure (notice that until now, my keyboard works) the screen where I select 'r' doesn't change.. think my keyboard isn't recognized?
  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

    If yours is an USB-keyboard, you may have a problem. Get a PS/2 keyboard to try instead.

    Do a scan on your PC for system
    You may have another older version to copy into that \windows\system32\config directory (e.g. from System Mechanic backup or \windows\repair)
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.