TechSpot Forums have received a major overhaul

By Julio Franco
Feb 13, 2015
Post New Reply
  1. We are happy to announce the TechSpot Forums have received a major visual overhaul and reorganization. We invite you to come over and check out what's new if you haven't been around lately. Internal discussions about these changes started several months ago and a lot of thought has gone into the new break down. We are very satisfied with the final result and we hope you enjoy it, too...!

    All PC hardware related discussion can now be found in a single place, while still being able to break down topics by subject, and then some -- you can filter down by Graphics, Audio, Storage, Input Devices, Displays (Monitors), Laptops, and more. There's also a new 'Build a PC' section dedicated to topics seeking advice on what to buy from scratch or when upgrading.

    We cleared the way for new forums: Google & Android, Internet & The Web (for discussing Tech Culture, Security, Social), an Electronics forum (Home Theater, Photography, Car Tech) and a new central place for all Apple devices.

    You may have noticed some inactive forums were silently delisted in recent months, while others have been merged. For example, the new Tech Support Forum is now all encompassing, but can be filtered by hardware, software or drivers support topics. These are just examples of the things you'll find to be different, but there are over 40 improvements meant to give the forums a fresh, more inviting face than ever before.

    Teaser alert: This is only the first on a number of things we have planned for 2015. An all-new TechSpot Deals section is coming, and it's set to debut by the end of this month.

    Permalink to story.

    Last edited by a moderator: Mar 6, 2015
  2. Siavash

    Siavash TS Enthusiast Posts: 65   +19

    What happened to the "Alternative OS" section and Linuxish posts? :D
  3. stewi0001

    stewi0001 TS Evangelist Posts: 1,136   +480

    More triangles!!!
    Jad Chaar and TheDreams like this.
  4. QuaZulu

    QuaZulu TS Enthusiast Posts: 59   +9

    Yes! I spent a few moments pondering whether they form a hill or a pit...
  5. Jad Chaar

    Jad Chaar TS Evangelist Posts: 6,477   +965

    Very nice upgrade TS! Keep up the good work!
  6. Julio Franco

    Julio Franco TechSpot Editor Topic Starter Posts: 7,022   +612

    The 'Alternative OS' forum was split. Apple related discussion went to a dedicated forum where you can filter by Mac/iPhone/iPad.

    Then Linux was merged within Apps & Software, but you can get to all Linux topics as well with ease here.
  7. Arris

    Arris TS Evangelist Posts: 4,587   +278

    To be honest I was waiting for an animation to zoom out and show me The Crystal Maze!
  8. stewi0001

    stewi0001 TS Evangelist Posts: 1,136   +480

    Why not both. Then we'd have a volcano!
  9. Siavash

    Siavash TS Enthusiast Posts: 65   +19

    That's much easier to navigate, thank you very much!
  10. Uncle Al

    Uncle Al TS Evangelist Posts: 1,491   +667

    I agree with everyone, it looks better and functions better. In fact the only complaint I have ever had was the practice of mixing advertising with news articles, but it looks like that was stopped? Hope so!
  11. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,430   +2,822

    I see a Jack O'Lantern!, amidst all the orange.
  12. jobeard

    jobeard TS Ambassador Posts: 9,143   +597

    You may find this of interest:
    • empty cache
    • 101 requests to server
    • 2,541.52 kb downloaded
    • 6.48 seconds
    • with cached data
    • 84 requests
    • 1,523.88 kb downloaded
    • 4.87 seconds
    • iPad empty cache
    • 92 requests
    • 2,140.15 kb downloaded
    • 6.65 secs
    • cached data
    • 83 requests
    • 1,505.28 kb downloaded
    • 4.76 seconds
    The bandwidth is heavily impacted from downloading large number of graphics of the same resolution regardless of the target user device.
  13. Julio Franco

    Julio Franco TechSpot Editor Topic Starter Posts: 7,022   +612

    Which page were you testing? Homepage, forum home, other?
  14. war59312

    war59312 TS Booster Posts: 114

    Ever thought of enabling CloudFlare with SSL?

    Would be nice!! Would speed up everything and more secure with real SSL. :D Please!
  15. jobeard

    jobeard TS Ambassador Posts: 9,143   +597

  16. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,430   +2,822

    You guys are continually breaking the site. It currently looks like trash. But then in an hour or so it will look fine. I've tried clearing browser cache and even rebooted. All the content loads but the structure is non-existent. Everything is on the left side of the screen. I've been noticing this phenomenon for a month or so at odd times.
  17. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,430   +2,822

    Let me share a screenshot of the issue I've seen very frequently the last few months.

    Attached Files:

    • TS.jpg
      File size:
      50 KB
  18. TheBigFatClown

    TheBigFatClown TS Guru Posts: 643   +226

    The "filter" tag is overkill. I don't need to be reminded that I am looking at a page of "Network" posts by embedding a "Network" graphic in "every" post. Just my opinion. I think once at the top of the page is sufficient but otherwise, other than the complaints that I have, I really have no complaints. :)
  19. captaincranky

    captaincranky TechSpot Addict Posts: 11,456   +1,759

    To be perfectly honest @Julio Franco , nothing would make me happier, than to have some of the original functions restored in the posting box. For example, the ability to wrap text in quotes without directly hitting 'reply'. The text size option. The option to line out a word. And perhaps most significantly, the ability to edit a post after 2 hours. A syntactic or spelling error on my part, annoys me for days. Plus, I would like the archives to think of me as someone who understood his native tongue. Attained functional literacy, as it were..

    Well, those things, and at very least a, "rolleyes" emoticon. That would save countless of half pages of, "I was being sarcastic", "well you're going to have to get better at being sarcastic if you want the rest of us to pick it up", blah, blah, ad naseum.
  20. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,430   +2,822

    I have another screenshot
  21. Julio Franco

    Julio Franco TechSpot Editor Topic Starter Posts: 7,022   +612

    I believe the tags along the posts titles are valuable and are part of the whole rethinking of the forum. However, to alleviate the noise they can potentially create I've modified them so all filters are almost the same width, whereas before "CPU" and "Networking" had very different sized buttons, and made scanning post titles a bit of a challenge. In other words, post titles are now about on the same vertical alignment regardless of the filters.

    @cliffordcooley that is essentially your browser not loading the CSS stylesheet. There's been rare instances of this happening widely when we update and the CDN doesn't cache properly, but it's not common and no one in the staff or outside has mentioned this in quite some time. I must assume it's something in your browser, perhaps some add-on?
  22. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,430   +2,822

    All I know is I am no longer using the same OS install I was 4 days ago. Using a system image from Feb of 2014 has had no effect on the issue. Upgrading Firefox versions from 26 to 35 after the restore and changing 2 of the 4 add-ons I use hasn't changed the issue either. And if I used any fewer add-ons, I wouldn't have any installed. Before disregarding my issue, ask yourself why Techspot is the only site I have this issue with. And it is not all of Techspot. It is random pages/articles (usually when wanting to "Read More" from the forum side) that doesn't load the following links. I never seem to have the issue on the forum side.

    My Extensions:
    1. Speed Dial [FVD]
    2. WOT
    3. Some theme (I don't remember the name), now changed to Classic Theme Restorer
    4. Adblock Plus, now changed to uBlock
    That leaves Speed Dial or WOT, which of the two might change or interupt a page loading?
  23. Julio Franco

    Julio Franco TechSpot Editor Topic Starter Posts: 7,022   +612

    I'm not disregarding but I'm clear on what the issue is and the random nature of it (some pages only) makes it even more rare since we use the same header and stylesheet call site-wide (home, news, reviews, downloads, etc.) and another for the forums. Regardless of this, I just reset the stylesheets on both ends earlier today before responding above.

    Another possibility would be the CDN acting up in your area. Though the CDN's US servers are supposed to have the most reliability and redundancy of all, but who knows...
  24. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,430   +2,822

    I Installed Windows 10 Technical Preview this morning on a completely different computer. Guess what, I discovered while visiting Techspot? That's right Internet Explorer on a completely fresh install has the same symptoms. I've not had a chance to install anything because I'm faced with a network issue locking me out of my application storage location.


    Go ahead and disregard if you wish. Different machine, different operating system (fresh install), different browser, no add-ons installed, and I still see the same issue.
  25. Julio Franco

    Julio Franco TechSpot Editor Topic Starter Posts: 7,022   +612

    Same ISP though? If yes, please give me that information privately so I can open a request with our CDN provider (Turbobytes). Thank you.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...