the low fps thread didnt help!

By chublub
Aug 13, 2007
  1. i updated my drivers and is running good.
    but wen i start games i get very low peformance in CS and WoW i get 4 fps in major CS i get 30 then whenes theres heavy action i get 10.
    im guessing my ram could be the problem. a while ago my uncle booted my comp with the windows CD and erased everything so its ran like new. but my games were all running poorly. plz help
  2. MetalX

    MetalX TechSpot Chancellor Posts: 1,388

    We need you to A) Speak with proper English, and B) Post your system's technical specs.
  3. TimeParadoX

    TimeParadoX TS Rookie Posts: 2,273

    The way to post your system information is going to Start > Run > and type DXDIAG, a message will popup just click yes then either take a picture ( use printscr above the numberpad or next to the F12 button ) or do SaveAllInformation then attach it to your next post.

    Also try this:

    You have to download the ActiveX from the site for the test to work.

    Run a test for World of Warcraft and Counterstrike: Source

    If you get recommended you system is awesome!

    If you get a minimum pass then upgrade your system to the stuff it needs ( videocard, RAM or something else like that )

    If you fail do the same for the minimum pass results

    Hope I helped! :wave:

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...