TechSpot

Thinkpad took a dump today & I'm baffled

By beanknotty
Apr 2, 2007
  1. was working on the laptop when it froze and went to the BSOD (black screen). Did a hard reboot and it came to the win load page with the option to start in last known good config/safe mode/etc. No matter which one I try it loops back to this screen. Tried to use XP repair on my install disk but it won't let the disk run that far. It says i386\halacpi.dll could not be loaded error 7 cannot continue. so i tinked with my bios settings and got 2 other error messages along the way : unmountable_boot_volume and ftdisk.sys is corrupted. did my hard drive or my mainboard take a digger? I have never not been able to use the repair or reinstall option before....of course i didnt back up lately....lol. any advice is appreciated. thx. I have a stock thinkpad r31 except memory, which i upgraded to 512 mb (max for this machine) I run XP Pro SP2.
     
  2. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    hard drive could have died. this is common.

    replace drive.
     
  3. beanknotty

    beanknotty TS Rookie Topic Starter

    anyway to test it before i replace it? thx!
     
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Yes, you can use the manufacturer utility to test the drive. In a ThinkPad the drive is most probably either an IBM or Hitachi. So get the DFT utility from Hitachi and run a full test.

    Also, testing the system RAM can't hurt.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...