TechSpot

Totaly infected nothing i try works at all

By gilbey
Feb 1, 2010
  1. i am running vista and for no apparent reason started having problems

    In the bottom right hand corner instead of a globe there is a red x and when you hover over it, it reads connection status: unkown class not registerd.
    Internet explorer and i tunes dont work,
    The sound has stopped working altogether,

    nothing i have tried has worked at all,any one know how i can fix any of these problems?
     
  2. laptox

    laptox TS Rookie Posts: 38

    What else makes you think this is a virus ?

    I would run a virus scan - then download malwarebytes - run a full scan - then take it from there
     
  3. raybay

    raybay TS Evangelist Posts: 7,241   +9

    The infestation may not be as important as some hardware problem.
    What memory is installed? What is the hard drive, and how old?
    As Laptox suggests, run a variety. It always takes three to rid your system of most stuff. I would run the free Aivira Antivir, MalwareBytes, SuperAntispyware, Windows Defender, and Microsoft Security Essentials, and take notes on the results. You can also scan with SpySweeper and Spyware Doctor to decide whether to buy them or not... based upon scan results.
    Or you could use AVAST instead of Avira... but Avira is easier, though it takes longer to scan.
    I would also run the free version of MemTest for four hours or seven passes on one memory module at a time to be sure it is not a memory issue.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...