TechSpot

TV audio problem

By andy06shake
Jun 18, 2010
  1. I seem to be having some difficulty using my LG5000 TV as a second monitor. I am connected via an HDMI cable from the TV pluged in to a HDMI to DVI dongle connected to the second DVI port on my GTX275 card. I can display windows fine but for some reason i cant seem to get any sound from the PC on the TV. I have tried conecting the PCs audio to the TV via phono plugs to the R&L ports on the TV and PC but still no sound. Can anyone help please?
     
  2. ucould2

    ucould2 TS Enthusiast Posts: 335

    Assuming you have these card interfaces?
    [​IMG]
    Which DVI connection?
    [​IMG]
    is this your TV?
     
  3. andy06shake

    andy06shake TS Maniac Topic Starter Posts: 327

    DVI-D (Single Link)
     
  4. andy06shake

    andy06shake TS Maniac Topic Starter Posts: 327

    yes thats my TV, the 42" version. Also my GTX275 has only 2 DVI ports.
     
  5. ucould2

    ucould2 TS Enthusiast Posts: 335

    Scour the web sites for a DVI to HDMI adapter that will patch in the Audio signal. The problem may be that the computer is not putting through a signal, this should be able to be patched through with the correct adaptor
    [​IMG]
    this one is you?
     
  6. andy06shake

    andy06shake TS Maniac Topic Starter Posts: 327

    I allready have an Nvidia DVI to HDMI adapter conected, from the GFX card output DVI port to the Nvidia dongle to the TVs HDMI port.
     
  7. ucould2

    ucould2 TS Enthusiast Posts: 335

    The problem might be occurring because the DVI-D (Single Link) typically does not carry any audio data or the TV is expecting encrypted data signal using the HDCP protocol for copy protected content.

    Hope this helped
     
  8. andy06shake

    andy06shake TS Maniac Topic Starter Posts: 327

    Ok, so why when i connect the PC to TV via the audio jacks do i not get the sound this way?
     
  9. ucould2

    ucould2 TS Enthusiast Posts: 335

    <To test the Encryption part you could make a movie and see if this plays as a DVD (or what ever type of disc type it is you experience no audio with DVD-R, DVD+R, DVD-RW, DVD+RW or DVD-RAM)?
    <I could not see in the specifications "audio jacks" this may be your referring to something else because I think "audio jacks" pre-dates what your TV has?
    <In your GTX 275 specifications (nice looking card btw) it mentions "Two Dual Link DVI" and if you compare the picture, to the above references you can clearly see that the connector is "DVI-I Dual Link" this is capable of transferring audio data but if this is connected to a "crossover jack" that is a DVI-Single Link as you've suggested, then that may be the problem?
     
  10. McZigger

    McZigger TS Rookie

    Audio problem

    It used to be that when connecting your computer to your TV that it required VGA or DVI & a separate audio lead.

    Newer TV's now support Sound between your PC and the HDMI (DVI-I or DVI-D) Socket.

    In order for this to work you have to have a video card that supports SPDIF. You can purchase a cable which connects your sound card to your video card within the machine itself. On notebooks this should already be possible, or you may have to change a setting in your video driver to enable this option.

    So what is happening is that your TV is detecting HD through HDMI which includes sound. This has the effect of shutting off all other sound sources i.e. your separate audio cable. So this is why you do not get sound.

    To test this on your set: Play music on your PC connect your audio cable as you would have done with older tv's. Then select another input source on your TV. You should hear sound from your PC... but no picture.

    If this is so on a desktop PC then you will have to buy an SPDIF cable to connect your video & sound together. On a notebook look into the drivers for the enable audio option (You may have to do this on the desktop with SPDIF as well).

    There are numerous other solution which work but only until the PC is restarted then you will have to apply the solution again... which is a pain.

    So Desktops - buy the SPDIF cable, Notebooks change the audio settings within your video card drivers to "audio on".
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.