TechSpot

Two problems with Windows XP

By amalsk
Sep 28, 2013
Post New Reply
  1. Well...! I don't know if I am posting in the right place. I have a windows xp with service pack 3. I am facing two problems:

    1. I recently read somewhere that autorun.inf file was dangerous, so I deleted that file from my USB drives. I guess I made a mistake, is there any way to have the file back so that whenever I plug in the devices, it shows the autoplay menu? my device works fine but any way I could get the autorun.inf file?

    2. I guess the second problem was due to the deletion of the autorun.inf files from usb drives and somewhere else on my pc. now even after installing the drivers for my scanner, it wont detect the drivers. what I mean is, when I plug the usb of my printer to my pc, it says found new hardware and searches for the device drivers and says that no driver was found. I then found that the scanner was listed as usb device(with a yellow question mark) under other devices in the device manager. and I can't find an autorun.inf for the scanner driver to install. I have a benq scanner 4300u.


    hope somebody can help me?
     
  2. cliffordcooley

    cliffordcooley TechSpot Paladin Posts: 6,003   +1,503

    1) Autorun.inf file is not dangerous unless it has been physically linked to Mal-ware. Autorun.inf is basically a pointing file much the same as creating program links. The purpose is so the media executable doesn't need to be named the same or placed in the same location, for the media to autostart. Autorun.inf files have been used since the creation of application CD's.

    Simple layout of autorun.inf, where open is the application to autorun and which icon is associated with the media. The 1 is an indicator of which icon in the library to use. If the location is within a folder use "\" to separate the folders. An example is "OPEN=Folder1\Folder2\Setup.EXE".
    Code:
    [autorun]
    OPEN=Setup.EXE
    ICON=Setup.EXE,1
    2)Removing or running autorun.inf file would not have any effect on drivers. If you see a yellow question mark in Device Manager, it usually means the device was not installed. Search for drivers to your scanner and printer, if they have a yellow question mark.
     
  3. amalsk

    amalsk TS Rookie Topic Starter Posts: 33

    My scanner used to run fine...! the only thing is I can't find a way to install a driver for 'usb device' which is actually my scanner. it just searches and says that no software was found or something like that.....! :(
     
  4. cliffordcooley

    cliffordcooley TechSpot Paladin Posts: 6,003   +1,503

  5. amalsk

    amalsk TS Rookie Topic Starter Posts: 33

    Well, that's what I tried. when I try to install, it doesn't recognize my scanner and thus it fails to install it. I dont understand why all of a sudden this problem happens...! I also saw that this driver which you gave was bundled with that usb scanner driver, still...! am I doing anything wrong? please help...
     
  6. gbhall

    gbhall TechSpot Chancellor Posts: 2,346   +49

    It can be important to do things exactly in the order specified in the benq manual. It might be that you must first plug the USB lead in and only then switch the scanner on, or some other sequence. The same applies to the installation of the necessary driver. RTFM in other words.
     
    cliffordcooley likes this.
  7. amalsk

    amalsk TS Rookie Topic Starter Posts: 33

    Well, there isn't such a manual with it. And I read the read-me file too. Doesn't help. The only thing is whenever I connect my scanner's usb port to my pc, it says found new hardware. When I try to install it automatically, it searches for the software for 'usb device' and not my scanner and finally says that it cannot find the software to install it. When I try to install it manually, it needs some autorun.inf file which I cannot find at all!

    More help please............! Anyway, thanks for your help until now guys. Please help me get my problem solved...
     
  8. mailpup

    mailpup TS Special Forces Posts: 8,443   +220

    For manuals and drivers I recommend that you always try going to the manufacturer's website for them. Go here for the latest driver from Benq: http://benq.co.ae/page/?pageid=4&plid=1003&pid=732&s=1

    Click on the "Driver" tab and download the latest driver and click on the "Manual" tab to download the scanner manual.

    Before installing this driver I recommend uninstalling any existing scanner drivers that you find in "Add and Remove Programs" in the Control Panel. If you find none, then go ahead with the installation of the new driver.
     
    cliffordcooley likes this.
  9. amalsk

    amalsk TS Rookie Topic Starter Posts: 33

    Still no luck...! :( Anymore help?
     
  10. mailpup

    mailpup TS Special Forces Posts: 8,443   +220

    Try a system restore to a point before you deleted the files.
     
    cliffordcooley likes this.
  11. bazz2004

    bazz2004 TS Maniac Posts: 448   +53

    I suspect that the BenQ 4300u is ancient with a usb1 connector and may well have compatibility issues with XP. I bought an HP 4200c or 4300c scanner. Initially, when I ran Windows 98, it was great. After upgrading to XP it never worked properly. That remained true even when so called XP drivers were released. It was a shame to replace it but mine went to a recycling station. You may have a real battle to get the scanner going again.
     
     
  12. amalsk

    amalsk TS Rookie Topic Starter Posts: 33

    Well, I don't think of the System restore idea.... :( Even with the latest driver, I get the same problem. I suspect I removed some program from the windows Add/Remove programs while cleaning out my system of unwanted and unused software which might've caused this.
     
  13. bazz2004

    bazz2004 TS Maniac Posts: 448   +53

    There's plenty of info out there about the scanner and nothing about problems with it. The Mirascan v4.03 driver you have downloaded isn't being found by XP's hardware installation Wizard. If you have a blank CD perhaps it would be worth burning the software to it and trying to install the scanner that way.
     
  14. mailpup

    mailpup TS Special Forces Posts: 8,443   +220

    What does this mean? It doesn't make sense to me.
     
  15. amalsk

    amalsk TS Rookie Topic Starter Posts: 33

    Will see that way and reply if it works...! :)

    I am not in a situation to system restore actually. :)
     
  16. hood6558

    hood6558 TS Booster Posts: 292   +44

  17. gbhall

    gbhall TechSpot Chancellor Posts: 2,346   +49

    Have you actually installed the driver or not? In other words, is it that the hardware will not recognise the driver, or that the driver will not install? According to your original post, you can install the driver, but switching on the device it asks for the driver, you set it to search but it does not find the driver?

    If this is the case, it should be just a case of when the driver is requested, you take certain options that allow you to select the path where the driver is already installed, and in many cases you may be told it is not the appropriate driver, but you can still force it to be used....successfully.
     
    cliffordcooley likes this.
  18. amalsk

    amalsk TS Rookie Topic Starter Posts: 33

    sure! :)

    Well, the driver is installed but my PC doesn't recognize it! The thing is when I manually search on the locations for the driver, the default option is to search for autorun.inf files which I cannot find on the installed path. It only searches for .inf files and nothing other...!
     
  19. bazz2004

    bazz2004 TS Maniac Posts: 448   +53

    Although it sounds easy if you have the drivers I had a similar headache with an internal Ralink 2500 usb wireless card. Periodically it would cease to work properly and trying to reinstall it drove me to distraction. There was a problem with getting the hardware wizard to find the installation files and Windows kept trying to install its own drivers as soon as I booted up. I can't really explain it properly but I've been there. I now use an ethernet cable for that computer.
     
    cliffordcooley likes this.
  20. cliffordcooley

    cliffordcooley TechSpot Paladin Posts: 6,003   +1,503

    I had similar issues with a Bluetooth Adapter. For some reason I couldn't keep it functioning. And to reinstall, it took multiple installs. I finally said the hell with it, and threw the thing in a drawer. Thats the only device I have had repetitive troubles out of.
     
  21. gbhall

    gbhall TechSpot Chancellor Posts: 2,346   +49

    When I download and unzip the driver referenced in post#8 I get the following files. Notice they date from December 2003, but XPsp3 was not issued until April 2008, and so I suspect those posters who are suggesting the driver will not work, having not been updated for XPsp2 let alone sp3, might well be right.
    Having unzipped the driver package as below, you MUST then run the setup.exe visible in the top-level directory.

    Clip0003.png

    That process of driver install I have not tested, to relieve me of the possibility of having unremoveable junk littering my PC. But if it does what would normally happen, it would offer a choice of language and maybe optional facilities and then copy the directory structure to system32\drivers and insert some registry values. I have to say that there are no obvious hooks for a USB capabiity.

    In the CAT directory there are four files referring to 98..., 2K..., ME... and XPSCAN07.in_ which would be the one for XP, and it is possible to tell that will be expanded to XPSCAN07.inf (and another called sti.inf - something to do with 'still image') Do a full C:\windows\ search for XPSCAN07*.* and include hidden files.

    You would need to point the driver search to that file - probably in c:\windows\system32\inf or could be elsewhere. Your best bet if you can't succeed would be to buy a MFD (multi-function device printer/scanner/fax).
     
  22. amalsk

    amalsk TS Rookie Topic Starter Posts: 33

    Does not work bro.

    I even tried installing from 'Have a disk' and selected XPSCAN07 and it says the specified location does not contain info. about your hardware.

    My best guess as I said above is I think I might've uninstalled something from Add/Remove programs long before. After that, the problem started. The thing is I don't know which one it was. I also can't do a system restore as I have so many programs installed now. My best guess is that it was related to some Nokia PC Suite/OVI Suite or something. And I still remember that when I uninstalled it, It said some programs might not work.
     
  23. cliffordcooley

    cliffordcooley TechSpot Paladin Posts: 6,003   +1,503

    We wasn't asking you to do a system restore, it was a system restore point. Restore points will take you back to the last time a restore point was created. It could be anywhere between 5 minutes to several years, depending on how frequently there are system changes done to prompt the creation of a restore point. The amount of space alloted for restore points will dictate how many points are available when needed.
     
  24. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

    1. Look in Add/Remove Programs. Look if any entry about the scanner and uninstall if there.

    2. Let''s check how your machine is config'ed to handle unsigned divers
    > Right click My Computer->Proprties->Hardware.
    > Click "Driver Signing". If it' set to Block, that could be your problem. Set it to Warn and check Make action System default. Click OK. I don't remember if you also need reboot. If you get a warning message about unsigned drivers when you install click Continue.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.