TechSpot

Unable to Link Photos with ".PNG" File Extension in Forum

By captaincranky
Feb 22, 2016
Post New Reply
  1. It has come to my attention that a fellow member found it impossible to link photos to be included in a post, which contained the ".png" file extension.

    The point has been made that ".png", is intended to represent, "portable net graphics", hence the confusion.

    1: So, is this an active, current glitch, in the forum software?

    2: Or, are images with the ".png" file extension, being excluded with good reason?

    3: Could this be a case of, "pilot error", or a copyright issue coming from the point of origin?
     
    Last edited: Feb 22, 2016
  2. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,555   +2,898

    png-ext.png

    [​IMG]



    First image was uploaded from my machine. Second image was linked from my file sharing. Both images are the same.
     
  3. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,555   +2,898

    Lets try this again.
    [​IMG][​IMG]
     
    captaincranky likes this.
  4. captaincranky

    captaincranky TechSpot Addict Topic Starter Posts: 11,695   +1,884

    The following data is extracted from Firefox' "view image panel". ("Page Info", if you prefer)

    Location: http://2.bp.blogspot.com/-6qf7o7MkkM0/UNEEsNeBPmI/AAAAAAAAARo/cOyHRqCVxO8/s1600/minnie+mouse+EN+PNG.png

    Type: PNG Image

    Size: 580.64 KB (594,572 bytes)

    Dimension: 889px × 1,600px (scaled to 831px × 1,496px)

    Type: [​IMG]

    EDIT: Note the forum added the broken link icon where I even tried to paste "[-I-M-G-]"

    (Note also that the broken link icon was generated by our software, from the image link Cliff successfully posted, in reply #2 )!
     
    Last edited: Feb 22, 2016
  5. LNCPapa

    LNCPapa TS Special Forces Posts: 4,210   +424

    Most of the images I post are png - it's a superior format to jpg and I'm a bit of an A/V/P snob. The problem in that last link CC is the link itself. Convert those "+" symbols to "%2B" and it will work.
    [​IMG]
     
  6. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,555   +2,898

    I figured there was a problem with my link, which is why I tried again with png file I found elsewhere. This doesn't seem to be a problem if the link format is supported. If the link format is not supported the image will not display regardless what the file format is.
     
  7. captaincranky

    captaincranky TechSpot Addict Topic Starter Posts: 11,695   +1,884

    OK, the link information I posted, was from the photo Cliff successfully posted. I copied and pasted the info directly from the "page info" window in Firefox. If I'm reading what you've posted correctly, the image shouldn't be up, OR, Firefox has converted "%2B" back to "+" on its own.....? :confused:
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...