Unknown device shown in device manager

By g4mer
Aug 18, 2010
Post New Reply
  1. Does anybody know what this device does. It's located under SCSI and RAID Controller, it's called AWFOEXCS IDE Controller. I have no idea what the hell is that.

    Attached Files:

    • IDE.JPG
      IDE.JPG
      File size:
      43.6 KB
      Views:
      10
  2. jobeard

    jobeard TS Ambassador Posts: 13,284   +281

    I've seen those on the Media Center edition of Windows
  3. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,358   +167

    You have several device problems... Are you only concerned with AWFOEXCS IDE Controller?

    In any case, please
    • Make sure all your devices are connected and powered on
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    Generate and attach a DirectX report
    • click Start->Run, enter dxdiag
    • Notice progress in lower left window corner
    • When done, click Save Information button and save to your Desktop
    • In TechSpot, use the paper clip icon to attach the report. (If you don't see icon you may need to first click Go Advanced)
  4. g4mer

    g4mer TechSpot Enthusiast Topic Starter Posts: 340

    I have Windows XP Professional 32bit.

    Yes, those other devices are from my TV card and enthernet card.

    This is what i get:
    AWGOEXCS IDE Controller ACPI\PNPA000\4&5D18F2DF&0 39
    Multimedia Controller PCI\VEN_14F1&DEV_8801&SUBSYS_6618107D&REV_05\4&13699180&0&4948 The drivers for this device are not installed.
    Multimedia Video Controller PCI\VEN_14F1&DEV_8800&SUBSYS_6618107D&REV_05\4&13699180&0&4848 The drivers for this device are not installed.
    PCI Simple Communications Controller PCI\VEN_8086&DEV_1040&SUBSYS_10008086&REV_00\4&13699180&0&3848 The drivers for this device are not installed.

    I uploaded DxDiag document...here you go.

    I searched for this on Google, i can't find anything...

    Attached Files:

  5. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,358   +167

    So the machine in question isn't the one in your system specs, right? As appears the machine you're talking about:

    > Is XP (as you mentioned)
    > Did you know it's still running Service Pack 2? You should probably upgrade to SP3 sometime (tho this isn't what's causing your problem)
    > Computer seems to be an MSI MS-7125, yes??

    As to your problem devices:
    > Multimedia controller seems to be some type of chip for TV?
    > The simple communications controller is an onboard modem

    The one you asked about isn't a Plug and Play driver. Will see what i can find and get back to you when i can
  6. g4mer

    g4mer TechSpot Enthusiast Topic Starter Posts: 340

    - I have Windows XP Pro SP2 32bit - i dont want to upgrade to SP3, plus, i know that won't solve the problem.
    - Yes, it's MSi K8N Neo4 Platinum (PCB 1.0) MS-7125
    - Multimeda controller is for TV which i don't use
    - Simple comm. controller is an onboard modem - Correct!
    Your right about everything :D:D

    I didn't mention that i had Virtual Machine and Deamon Tools Installed before and now they're removed.

    Should i try to uninstall that device and see what will happen??
  7. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,358   +167

    If you uninstall it will simply remain uninstalled. The device in question isn't a Plug and Device which means Windows doesn't detect it on its own. If the driver removed it will "simply disappear" from sight

    This device in question might be a real device or a "pseudo" device (which you won't really need) i'll let you know what i can find out :)

    I'd leave it as is for now
  8. g4mer

    g4mer TechSpot Enthusiast Topic Starter Posts: 340

    ok, thanks for help :)
  9. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,358   +167

    Thanks for that "heads up"!!

    As, in fact, it appears that "AWGOEXCS IDE Controller" is most likely a "virtual device" created by your tools. Its device definition and driver were left behind when you uninstalled the tools

    While is probably OK to simply uninstall it, IMHO is wise to take a few extra minutes to first be cautious
    1. Backup your current drivers. See How to backup your drivers (and reinstall them later if and when needed!)

    2. Create a Windows System Restore point (just in case you should need it later)

    3. Now rt click the device in DevMgr and Uninstall it

    4. For those other 3 devices, i'd recommend you rt click and Disable them. (it's otherwise minor overhead, but if not disabled, Windows will keep trying to look for thier missing drivers and restart those 3 devices you know that you don't really need: Once on reboot and again and again periodically after Windows is started

    /* edit */
    Other 3 devices being .... the 2 media controllers and the simple communications controller

    /* edit2 */
    BTW... just a note for anyone reading the thread in the future: The reason i'm being especially cautious in uninstalling the "AWGOEXCS IDE Controller" is specifically BECAUSE it is a not a Plug and Play device
  10. g4mer

    g4mer TechSpot Enthusiast Topic Starter Posts: 340

    I did everything as you told me....Everything worked....When i restarted my PC i got a new device there called AQH4BAF2 IDE Controller.

    Here's screenshot:

    I didn't mention that i have dual boot Windows 7 with this Windows XP and i have Virtual Machine installed on Windows 7 now. Maybe Windows 7 VM is creating that hardware over and over again because it's still installed in Windows 7.

    Sorry for my English.

    Attached Files:

  11. g4mer

    g4mer TechSpot Enthusiast Topic Starter Posts: 340

    I rebooted to Windows 7 and went into Device Manager and there was no that device installed:

    ***EDIT*** Deleted VM from Windows 7 and i still have that device in Windows XP...

    Attached Files:

     
  12. g4mer

    g4mer TechSpot Enthusiast Topic Starter Posts: 340

    No such device when i boot into safe mod.

    I found this thread same as mine....
    hFFFp://www.tomshardware.co.uk/forum/247412-14-weird-inexistent-controller

    ****EDIT****
    When i try to update that device i get "The specified device does not exist....and then i get message "New hardware found" SCSI/RAID Host Controller but it can't find the correct drivers.
    Here are some pics...
    Im sure this has to do something with DAEMON Tools...

    EDIT ----***PROBLEM SOLVED****

    Attached Files:

  13. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,358   +167

    You did some good research :grinthumb

    And, yes, everything you saw on your own machine (and in other thread) is consistent with this being a virtual device. Stuff left over (not removed) during your Virtual and Daemon tools uninstall was allowing that"virtual device" to be "redetected" and reinstalled - after you uninstall it.

    (It's kinda like some types of devices (like a CD/DVD) : You uninstall them. But after a reboot, they automatically reinstall themselves

    But did your EDIT say you finally solved the problem? It no longer reinstalls itself?? Now i'm curiouis.. What did you do? What did you remove in this case to fix it?

    /* edit */
    Now i'm just wondering how Daemon Tools implemented automatic device detection of a non-Plug and Play device... By chance
    > Was there an automatic startup program that started the "detection"
    > Maybe part of Daemon Tools still running as a Windows service??
    Just curious... and just trying at guesses now! :D
  14. g4mer

    g4mer TechSpot Enthusiast Topic Starter Posts: 340

    Not so long ago, i deleted DAEMON Tools folder because there was no uninstall option in Add or remove programs (BUT THERE WAS IN START MENU AND I DIDN'T SAW IT). Because of that, that unknown device left running in my Device Manager. So i thought that if i install Daemon Tools again, and then remove it, it will remove that device with it...and it DID!

    Maaaaan, i suck at English very very bad! I hope you understand what im trying to say.. Point is, it no longer reinstalls itself! Like you said.
  15. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,358   +167

    I understand perfectly :)

    From your description, it appears after your first uninstall/remove attempt, there was still a Deamon Tools Startup program left behind on your machine. (This startup program was the thing starting "pseudo"- device detection and the driver reinstall for the Daemon tool "virtual device")

    In any case, glad you have it fixed. And thanks for helping me learn a bit more about Daemon tools myself (and some of the things it does or doesn't do! :D)

    Best wishes for Happy Computing ahead :)
  16. g4mer

    g4mer TechSpot Enthusiast Topic Starter Posts: 340

    Thank you god!
    Correct!
    No problem and Thanks! :)


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.