Unusual behavior at system startup (Gigabyte MB)

By James Morgen
Apr 26, 2015
Post New Reply
  1. Hello everyone!

    I having a strange problem with my PC. Every time I start up my computer it just simply refuses to start. Let me
    explain what happens:

    I press to power button and:

    a) Everything begins to start, then I hear continuous "beeping" from the internal speaker. After 8-10 secs the pc
    shuts down and restarts then the "beeping" again for about 10 secs. This happens about 5 times then finally the pc
    starts to boot up BUT after that I get an error message that "MAIN BIOS CHECKSUM ERROR" so it starts to recover and
    one more reboot then FINALLY the pc starts normally...

    b) After pressing the power button nothing happens, after pressing multiple times (5-8x) the pc begins to start
    then the point "a" (what I mentioned above) comes...

    So every boot takes about 10 mins and its very very annoying... :(

    What I've already tried:

    - Replacing the BIOS battery with a brand new one
    - Updating the BIOS
    - Checking the font panel connectors on the Mobo. All of them are connected properly (Power switch, reset sw,

    - Removing USB devices didn't help.
    - I replaced the power supply even with a brand new one (320W)

    If anyone knows a solution please tell me because my mind is just about to blow...

    System specs:
    Motherboard: Gigabyte GA-G41MT-ES2L
    CPU: Intel(R) Core(TM)2 Duo CPU E7400
    RAM: 4GB DDR3
    GPU: AMD Radeon R7 240 (Oland)
    Power supply: Enermax EG475AX-VE(W) Noisetaker 320W

    I hope someone with better knowledge can help me out :)

    Thanks in advance
    James Morgen
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    Continuous beeps can mean that the video card has issues, but your power supply is a bit weak also...

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...