Urgh, Deleted Multimedia Audio sound

By Brendano108
May 22, 2005
  1. Im 14 and i need some help.

    I was on my computer and it was running slow so I went to control panel and then to add/remove hardware, thinking i had to much stuff on my computer so deleting some un-necessary items would help it go faster. Well, I ended up ACCIDENTALLY deleting Multimedia Audo Controller. Now I Get no sound.

    When I restart my computer or scan for new hardware, the computer says it found new hardware-Mutimedia Audio Controller, but in order to reinstall it, I need a CD-ROM I guess. Can anyone help. Do I need a CD-ROM or what. i need help but most of all I NEED SOUND
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    First go HERE for a list of things we need to know, and enter them into user profile at the top of any page(click on edit profile).

    Now depending on whether you have onboard sound or a seperate soundcard.
    You will need to go to either you mobo manufactureres website, or your soundcard manufacturers website, and download the sound drivers from there.

    Regards Howard :wave: :wave:
  3. Glowingold12

    Glowingold12 TS Rookie


    Im having the EXACT! same problem as him, im even the same age lol, today i was deleting alot of files but i accidently deleted multimedia audio controller, i tried to click that HERE link but it didnt bring me anywhere, Im not all the good at this technical stuff so im not sure how to check my soundcard and me other things, all I know is that my speakers... Wont speak, please help! :wave:
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...