TechSpot

Usb 3.1 slots showing code 10 error when attaching storage device

By Batrico
Dec 26, 2015
Post New Reply
  1. Sorry mods can you move this to storage.sorry

    Hi I purchased a new asus pc the other day.It came with windows 8.1 preinstalled with free upgrade to windows 10 64bit.heres what happened.
    I installed windows 10 and everything was fine.except Bluetooth has highlighted in settings with no option to turn it off.I clicked on windows update and it did a few updates plus a cumalitive update.after this the keyboard which was plugged into a usb 3.1 port stopped working.it worked in the bios but not after I go password screen after lloading windows.
    I changed keyboard to a 3.0 usb port and now I could use the keyboard.I restarted windows and connected a storage device to 3.1 usb port.it appears in the bios but once window loads it starts to open but errors.I checked device manager and it showed code 10 error on usb storage. tried uninstall reinstall many restarts to try fix the driver error.
    I used trobleshooter it told me it was a driver error and to try reinstall the driver.


    Any ideas if there is a fix or do yoou thing the next cumalitive update will fix it.
     
    Last edited: Dec 26, 2015
  2. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +241

    Have you check Asus support site. To see if maybe They may have update drivers for your USB 3.1 . For Win 10
     
  3. Batrico

    Batrico TS Enthusiast Topic Starter Posts: 55

    Thanks Cobalt I went to Asus website downloaded usb driver now all works again thank you.
     
  4. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +241

    Your welcome. Glad to hear.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...