1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

USB not working - need file usbehci.sys

By mmellish ยท 4 replies
Jun 4, 2006
  1. I had to get a new hard drive, and put in xp pro now usb does not work & error message that i need usbehci.sys file. I have googled for it and cannnot find where to download. I understand that it is a file new in sp1 - I have the xp home sp1 disks - can I somehow get it off of there. I did a search on the disk for the file it could not find it.

    Any help would be appreciated.
     
  2. kangaruffian

    kangaruffian TS Rookie Posts: 175

    download n install xp sp2
     
  3. mmellish

    mmellish TS Rookie Topic Starter

    thanks - got it working
     
  4. kangaruffian

    kangaruffian TS Rookie Posts: 175

    np :)
     
  5. jobeard

    jobeard TS Ambassador Posts: 9,852   +707

    look in \windows\i386 :)

    you can copy it to \windows\system32\drivers and then
    rename it appropriately. Be sure to DISABLE the device before the rename,
    reboot after, and then ENABLE to device
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...