TechSpot

USB not working

By lopdog
Nov 18, 2007
  1. Does anyone know any good reasons for my USB-ports to suddenly stop working? Since yesterday, any device I try to connect to any of my USB ports just dosn´t work, and XP pups up a message saying that "The device had a malfuncion and was not recognized by windows" or something like that. I think it is a problem with Windows, because when I turn on my computer the little LED on my USB-Stick turns on, and when windows starts loading it just shuts of. I´ve tried with diferent devices, and the same thing happens. Yesterday I uninstalled StyleXP, and after that my USB stopped working, but I don´t know if that´s the cause. Does anyone know about this situation?
     
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Uninstall all your USB-related devices in Device Manager, reboot and have Windows reinstall them automatically.
     
  3. Cerberus

    Cerberus TS Rookie Posts: 56

    hmmm.

    Go into your BIOS and check that USB is turned on, The BIOS controls the USB root hub...
     
  4. lopdog

    lopdog TS Maniac Topic Starter Posts: 295

    I tried to uninstall USB-related devices, but as soon as I press "uninstall", Windows automaticly detects the device and reinstalls, even before I can restart or uninstall other devices. And it still didn´t work.
     
  5. lopdog

    lopdog TS Maniac Topic Starter Posts: 295

    I discovered that if I disable USB 2.0 support in the BIOS, it works, but obviosly at lower speed. So how do I make it work with USB 2.0?
     
  6. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    If this happened after you uninstalled some software, you could try a system restore. It won't put back the software but it might restore whatever was changed in the registry.
     
  7. lopdog

    lopdog TS Maniac Topic Starter Posts: 295

    Sounds great. Unfortunately, I´ve disabled system restore (not a good idea in this case, I admit).
     
  8. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    OK -
    1) disconnect all USB devices
    2) reboot into safe mode and remove all the USB devices in control manager.
    3) reboot and reinstall USB ports and hubs, then reconnect all devices and reinstall.
    If this fails I would reinstall windows - overkill maybe but in my experience the only way to get a stable system again.
     
  9. lopdog

    lopdog TS Maniac Topic Starter Posts: 295

    I solved the problem by running the System File Checker. Now it´s working at normal speed again, no need to reinstall windows, luckily. Thanks, anyway.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...