USB PORTS are not working

By ostilad
Oct 5, 2007
  1. :BOW:
    Greeetings my fellow students and sensais.i have a problem and i know this is the best place to get new moves{not that i have any}.great teachers and students i just got another is an IBM moterboard ??? i'll get the number later processor pentium 4,hard disk 80 gig,.so the machine came with Windows XP installed but no sound and the USB ports 4 the flash stik not working.gav it to a it guy who got the sound drives installed after reinstalling windows xp.but the usb ports are not functioning .have reinstalled window xp but no luck.under device manager the usb ports r showing functional and wen i stik in my flash the flash light goes on but nothing appear on the desktop.will some boby pliz provide some steps to activate the me some new styles to use on this problem & i'll b greatfull.:BOW:
  2. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    This may be a faulty motherboard. Best and cheapest solution is to fit a card with USB ports on it.
  3. ostilad

    ostilad TS Rookie Topic Starter Posts: 18

    thanx great sensai.u r words hav wisdom but r complex for the simple mind.i have six ports on the do i know that i do not already have a card already fitted on with USBports?by the way the onez at the back r 4 and then i have two in front which r not connected.u wud humble this student with more of u'r wisdom.:BOW:
  4. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    Do they all work or not?
  5. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    the typical fix is to DELETE all USB drivers and reboot for autodiscovery.
  6. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    Agreed Jobeard: I was wondering if it was all of them 'coz from time to time the little card in the front panel can go pear-shaped. Another trick if this is the case is to unplug it as it can screw up the m/board as well.
  7. ostilad

    ostilad TS Rookie Topic Starter Posts: 18

    what I have discovered great sensais is,that my floppy drive is also not working even though i have enabled the drive via the startup menu setup.the light for the floppy drive is not even responding.even though the"device manager "is stating that the drives are in working order.none of the flash disk ports are working.the 4 at the back will only indicate that they r working by making the flash disk light up but not respond on the desktop. the 2 in the front aren't conected at all.anyway that is what i was told i haven't checked it out myself.the" floppy disk" icon when selected ater inserting a floppy will state please insert a diskette.could u pliz enlignten this student on how to "reboot for autodiscovery".humbly waiting 4 u'r reply sensais:BOW:
  8. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

    There are some floppy drives that will allow you to connect its ribbon cable in back wards. I have one, and when I've connected the cable in back wards it would always ask me to insert a floppy even if a floppy was already was in the drive.

    Reboot for autodiscovery means uninstall your USB ports from the Device Manager menu and then reboot your computer. Upon reboot your computer should find your USB ports and then automatically reinstall its driver.
  9. ostilad

    ostilad TS Rookie Topic Starter Posts: 18

    usb don,t work

    I happened to have tried to delete my usb port drive then reboot for autodiscovery.ya the pc did that but no luck the usb ports even though after autodiscovery won't just floppy is out as well afer enabling it.pliz help great sensais!:BOW:
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...