TechSpot

Very confused with *new* video card

By blinking
Dec 31, 2006
  1. I have just recently purchased a Visiontek ATI Radeon X1300 card for my computer, which is pretty much just a base model Dell Dimension 4550 from 2002 (except with 512mb more of RAM). My computer meets pretty much all of the basic minimum requirements for the card, but after I put it in the computer and try to start it up, it makes a constant beeping sound and I get no picture... I have no real idea of what to do.
     
  2. cfitzarl

    cfitzarl TechSpot Chancellor Posts: 1,975   +9

    Is the card seated properly? Here, check out this guide and follow step 3, http://www.techspot.com/vb/topic66390.html BTW, Welcome to Techspot :wave: ! Also, how long have you had the ram?
     
  3. blinking

    blinking TS Rookie Topic Starter

    I think it is, the fan spins, but it uses extra power so I thought it might be my power supply, but it seems to meet the minimum requirement. And thanks.
     
  4. blinking

    blinking TS Rookie Topic Starter

    I got the ram within the last year.
     
  5. cfitzarl

    cfitzarl TechSpot Chancellor Posts: 1,975   +9

    As I said look at step 3 of my guide and tell me the specs of your power supply. Dell doesn't manufacture their computers (lower models) with the greates power supplies.
     
  6. blinking

    blinking TS Rookie Topic Starter

    I think it has 12V, 15A, and max output 250W
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...