TechSpot

video card help

By jprime777
Apr 21, 2007
  1. i have a nvidia geforce4 video card, so i took my computer apart and plugged the card in. when i plug my moniter into the videocard slot it all goes black, anyhelp? there were 2 slots for a video card but one of them had a lot of wire running accross it and i didnt wanna unplug them
     
  2. Blakhart

    Blakhart TS Rookie Posts: 353

    Hi

    Is your vid card plugged in completely?
     
  3. jprime777

    jprime777 TS Rookie Topic Starter

    yes, its like my screen just turns off
     
  4. Blakhart

    Blakhart TS Rookie Posts: 353

    Ok so does your system have onboard grafix that you used before the gf4 card?
     
  5. Afandrafu

    Afandrafu TS Rookie

    Did you download the driver for the video card before you installed it. You must have a driver but if you cant see the screen to select it. i dont know what you should do.
     
  6. jprime777

    jprime777 TS Rookie Topic Starter

  7. Blakhart

    Blakhart TS Rookie Posts: 353

    Are you running as a limited account? You probably need admin status to do driver installs and deletions.
     
  8. jprime777

    jprime777 TS Rookie Topic Starter

    and how do i get admin status? the computer is mine i just have no idea what im up to
     
  9. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 3,481   +44

    lol I know this might be a noob question, but are you sure you have the right interface for the new card, just recently saw someone here that forced a card into the wrong slot.
     
  10. jprime777

    jprime777 TS Rookie Topic Starter

    nope, the card went in rather easily, nice and snug
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...