TechSpot

Video Card problems: black screen?

By cletus22
Sep 23, 2007
Topic Status:
Not open for further replies.
  1. I have a geforce 7900 GS, spec's are 2 gigs of ram, AMD 4600, VISTA 32 bit. It always worked, played oblivion and half life. Then I just stopped playing video games, and one day I came home...and my computer screen was pixelated, all multicolored...it overheated some how...when I wasn't even on the computer. Took the card out, let it cool down, put it back in, and it worked fine (didn't try any games). Then a few days later the same thing happened...but it DIDN'T work again. After trying to clean it, I put it back in...and I get a black screen when I boot up. I hear all the sounds, just no video. Is my card fried? Or is the connection just bad?
  2. kpo6969

    kpo6969 TS Maniac Posts: 875

    It could be your psu went bad. Or the card.
  3. cletus22

    cletus22 TS Rookie Topic Starter Posts: 17

    I can use my on board video and everything is fine, so It wouldn't be the psu right?
  4. pc techguy

    pc techguy TS Rookie

    what make is ur motherboard?
  5. cletus22

    cletus22 TS Rookie Topic Starter Posts: 17

    im not sure...got a gateway GT5414E...if that helps
  6. cletus22

    cletus22 TS Rookie Topic Starter Posts: 17

    ECS MCP61-P AM2 Motherboard...found that out
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.