Video drivers help

By Killerrampage
Feb 7, 2008
  1. Hello,

    Well i recently installed world of warcraft and instaleld it and everything and when i try to play a message pops up saying i need to update my video drivers and/or install directx9.0c i checked my computer and on it it says intel so i go to and started to download lastest video drivers but im not sure if i downloaded the right ones can someone give me the link to the latest video drivers from intel.

    My computer is windows XP
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

  3. Killerrampage

    Killerrampage TS Rookie Topic Starter

    system summary:

    Manufacturer : Compaq
    Mainboard : Asus Govii
    Chipset : Intel i845G
    Processor : Intel Celeron D 335J @ 2800 MHz
    Physical Memory : 256 MB (1 x 256 DDR-SDRAM )
    Video Card : Intel Corporation 82845G/GL/GV/GE/PE Integrated Graphics Device
    Hard Disk : ST380215A (80 GB)
    DVD-Rom Drive : LITE-ON COMBO SOHC-4832K
    Monitor Type : COMPAQ COMPAQ FS7600 - 16 inches
    Network Card : Realtek Semiconductor RT8139 (A/B/C/810x/813x/C+) Fast Ethernet Adapter
    Operating System : Microsoft Windows XP Home Edition 5.01.2600 Service Pack 2
    DirectX : Version 9.0c
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

  5. Killerrampage

    Killerrampage TS Rookie Topic Starter

    i click the green round button but nothing happens
  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    After a delay, you should receive a security message, install ActiveX control Yes
    This may come up as that grey that pops up at the top of IE page

    Once the activex is installed, you may need to go back and click the button again
  7. Killerrampage

    Killerrampage TS Rookie Topic Starter

    nope i dont
  8. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    You may wish to Print this page

    Inside Internet Explorer click on "Tools" on the toolbar
    (Note: in IE7, you may need to press ALT on the keyboard to see the IE toolbar)

    After clicking on "Tools" click on "Internet Options"

    The first window you are presented with will be the "General" tab settings
    Inside the "General" tab you can select "Delete..."
    The next popup window will ask you what to delete.
    You can select one button at a time, or "Delete all", answering Yes

    Once this is completed (and it may take some time to do) Continue on:

    Still in the General Tab
    Click on "Settings" (next to Delete)
    Change the "Disk space to use" to 65
    Select OK

    Now, go to the Security tab
    Click on "Custom Level"
    Click on "Reset"
    Click on "OK"

    Now go to the Privacy tab
    What I do in here, is move the vertical slider slighty up or down
    This allows "Default" to highlight
    Click on "Default" (the slider will come back down)
    Click on Apply

    At last go to the Advanced tab
    Click on "Restore advanced settings" (a bad way of saying default)
    Also if you scroll down the list, you will find "Phishing Filter" (I usually disable this annoying popup)
    Click on Apply
    Click on OK

    Restart Internet Explorer

    Now, please try that page again
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...