TechSpot

Vista having problems connecting to OS X 10.3.9 computer

By SNGX1275
Mar 24, 2007
  1. Last night I installed Vista Home Premium on a machine that previously had XP Media Center. Today I go to access my G3 computer and it asks for user/pass which is fine, it asked in XP as well. I enter my pass, just like I did in XP, and it returns an error saying "Logon Unsuccessful: Windows could not log you on. Be sure that your username and password are correct." Nothing on the G3 has changed since yesterday when XP worked.

    I've also noted that when it fails it changes my username from "sngx1275" to "MAIN\sngx1275". I'm not sure this is a problem, but thought it should be noted.

    It is a possiblity that Windows needs a reboot. At first when I opened the Network it said I had file sharing and network explorer or something off, so I turned it on. I think XP usually wants a reboot after that, but Vista didn't ask. So I could reboot, and probably should, but I'm doing something important now that I can't reboot the computer.
     
  2. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Are you sure you didn't have to tweak XP to make it work with OS X? I remember having to turn off some encryption settings to make XP work with Samba..
     
  3. jobeard

    jobeard TS Ambassador Posts: 13,515   +336

    of course your Vista System name is MAIN, but check the WORKGROUP name
    matches that stored on the Mac. The Vista firewall will need ports 137,139,and 445 to be opened.
     
  4. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,689   +334

    I always change the WORKGROUP to my last name rather than leaving it as WORKGROUP. I don't think you deal with any of that on OS X, but I have changed it in Vista, and the G3 does show up when browsing the network.

    I'll look into the firewall thing.

    Nodsu - no I'm not sure, but I don't think I messed with any encryption. I've got regular Windows Sharing and Personal File Sharing turned on on the Mac end.

    Edit: Explicitly adding those ports to the firewall didn't help any.
     
  5. Nodsu

    Nodsu TS Rookie Posts: 9,431

  6. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,689   +334

    Read the article. That sucks. But it doesn't say what the failure mode is.

    My little "workaround" to this at the moment is to take the rar'd files the G3 downloads and drag to the Windows share. Then extract on the Windows machine to a different dir, then delete the directory that was copied. It works, but it requires me to actually be at the G3. Much less convenient than browsing the share, right clicking on the rar and extracting to the local machine through the network.

    Edit: I do have a Powerbook running 10.4.9, I could try a share on that and see if I can get in. If it is the Samba issue I should get the same problem. 10.4.9 might have newer Samba, and also it could be something else screwed up in Windows, so I'm not sure if it is going to tell us anything. I'll try it anyway.

    Edit2: Found this, which gives a solution, I'll try it tonight.
    Basically Vista made it more difficult to get to an OS X share, and possibly killed network performance between the 2 compared to XP. Hooray Vista!!
     
  7. jobeard

    jobeard TS Ambassador Posts: 13,515   +336

    Under the Finder, using the GO menu, Connect To Server,
    an entry like smb://systemname/sharename will raise a prompt
    for Workgroup Name, Username, Password.

    I too change the WORKGROUP name; having the
    Property Name == Property Value is mindless --
    perhaps why it changed in XP to a default of MSHOME :)
     
  8. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,689   +334

    I think the Workgroup is correct for the G3, because in Vista I can see my workgroup as well as WORKGROUP, and my Powerbook is in WORKGROUP because I never messed with it, and whenever I needed to get to it in the past on XP (rarely) I just used IP. But that wasn't working on the G3. I'll edit this post later tonight when I have time to screw around with it. I think that link in my last post has what needs to be done on the Vista machine to make it work.
     
  9. jobeard

    jobeard TS Ambassador Posts: 13,515   +336

    hum; that fix has always worked -- I just did that from XP/Home to my OS 10.3.9 -- what's so new?
    was the drive mapped prior to the d-n-d?

    I use a sync program in a similar way, but I've learned to make sure the target
    drive is MAPPED and mounted before the d-n-d :)
     
  10. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,689   +334

    Nah, normally (in XP) I just had a shortcut to the G3, click that it prompts for user pass, I enter it and I'm in. (unless the G3s IP changed, in which case I'd browse to it in the network and create a new shortcut).

    But now I click and it prompts for user pass and I have done the following with no positive results:
    User as sngx1275 in the user box, password in password
    User as 192.168.1.102\sngx1275 in user box, password in password
    User as 192.168.1.102sngx1275 in user box, password in password
    manually entering 192.168.1.102\sngx1275 in the address bar, that prompts up the user pass box where I have tried the 2 above techniques

    I have a feeling we aren't on the same page here, because you keep asking or saying things that don't really fit with what I'm trying to do.

    So here goes again. I want to get to my G3, which has the local IP of 192.168.1.102 my username is sngx1275. I want to get in to there with that username and my password. In the past (XP) this would bring up all the folders, and I have full read write privs, from there I open the folder I want, and extract the files over the network to my Windows box.

    I CAN browse my Vista machine from the G3 just fine, but that is not what I am wanting to do.

    I tried the link I provided above, with no success. Earlier today I saw some information while I was looking for a solution and it involved editing the registry, and someone mentioned it wasn't even in Vista Home Premium, so I'm going to investigate that further.

    Another little piece of information is that I just tried to get to my Powerbook, by double clicking on it in the Network in Vista (Both the G3 and the Powerbook show up) and it prompts for user pass just like it does for the G3, and I enter them and I get let right in. So there may be some fundamental differences in how 10.4 vs 10.3 handles networking, either that or I have them set up differently. But the bottom line is something broke in Vista and is preventing access to the G3 like the way it did in XP or the way it does now for the Powerbook.
     
  11. jobeard

    jobeard TS Ambassador Posts: 13,515   +336

    OS X sharing accesses the userid\User\Public\Drop Box using the
    <system>/userid. When the access is granted,
    the current directory will be the Drop Box

    Yes, the Mac can access ANY Windows share, even C:\ using
    smb://system/sharename
    [/QUOTE]

    If you have been able to set a share on the Mac other than the Drop Box
    on Os X 10.3.9 I sure would like that feature too, but I've never seen any
    documentation since 10.1.* that supported that.
     
     
  12. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,689   +334

    I don't get access to the dropbox. I get full access to deskop, sngx1275 (user dir), applications, documents, movies, music, and pictures. I get the same listing you get with a fresh finder window. Thats how it works when I access the Powerbook or when I access the G3 from XP. I'm logging in with the same user pass as I use on the Macs themselves, not a guest account.
     
  13. jobeard

    jobeard TS Ambassador Posts: 13,515   +336

    >I'm logging in with the same user pass as I use on the Macs themselves.

    me too! just access to the dropbox however. AMAZING :)
     
  14. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,689   +334

    Here is how its done in XP.
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
     
  15. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,689   +334

    And this is how it goes in Vista:
    [​IMG]
    [​IMG]
    [​IMG]
     
  16. jobeard

    jobeard TS Ambassador Posts: 13,515   +336

    :blackeye: :knock: :p mea culpa! :knock: :blackeye: :p

    but of course! I use the drop box so frequently AND EXCLUSIVELY that
    I've been navigating straight to it without even trying to drop something elsewhere.
    With the right permissions you can drop anywhere.

    Sorry 'bout the confusion and I wasn't trying to argue or upset you either --
    just stating my different usage scenario -- cleary NOT applicable to you usage.

    Best wishes, Jeff
     
  17. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,689   +334

    Fair enough. It just seemed like you weren't understanding what I was saying, and I just moments before got XP up and running on my A64 machine, so I got the idea to take screenies. Then I fought with MS Paint to crop the things to what I wanted, ugh. Should have just taken the time to put Irfanview on.

    I'll look around some more later for the registry hack to get this Vista box to do what I want. I suppose I could just extract over the network to the A64 machine and deal with the stuff there. But that really isn't what I want to do, and its arguably easier to drop it to Vista from OS X, which again isn't what I need.

    EDIT: FIXED IT!!
    The site that had me typing in \\192.168.1.102sngx1275 has some problems with "\" displaying so thats why I attempted that (didn't think about them screwing that up at the time), but that site also has the reg hack. Which is how I fixed it. So I'm going to put the fix here.

    In regedit:
    Navigate to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    In the right pane, right-click the "LmCompatibilityLevel" key and select "modify"
    Change the value from 3 to 1
    Done

    Now to keep people from being pissed at me when they kill their system, I'm going to add this disclaimer: Make a backup of your registry before attempting this, and it wouldn't hurt to create a restore point either.
     
  18. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,919   +9

    Does that affect the networking performance?
     
  19. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,689   +334

    Should it? It seems pretty slow, but that may be because all recent transfers have been when there is heavy disk activity from other processes. Maybe tonight I'll test transfering the same file when using Vista and XP.
     
  20. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,689   +334

    Well I said I'd test the transferring vs XP.

    Here's what I found:
    Dealing with a 6.53GB single file, 100Mbps network.
    * Time to push it from Vista to the 10.3.9 Box 17 Minutes 20 Seconds
    * Time to copy it from 10.3.9 to Vista 16 Minutes 58 Seconds, unstable transfer, approx every 10 seconds the speed would drop to 0, peaks were slightly above 77% network usage.
    * Time to copy it from 10.3.9 to XP with Total Copy 1.2 15 Minutes 2 Seconds, visually it looked like 68% network usage fairly steady.
    * Time to copy it from 10.3.9 to XP with Windows copy 13 Minutes 49 Seconds, visually it looked like 72% network usage, also fairly steady.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.