Vista is on WAN, but cannot find/share files

By johnhenry
Dec 19, 2007
Topic Status:
Not open for further replies.
  1. Hey All-
    I've set up a WAN for my mother using a wireless Belkin router. The Belkin is attached to a desktop which is running XP. Her Vista laptop is able to see and use the network for surfing the web. No problem there. But the Vista laptop refuses to see the shared folders on the XP machine, and the XP machine cannot see/find the Vista laptop.

    Using my own XP laptop this is all very simple. I simple set the 'Shared' option on the folders on the desktop, then on my XP machine navigated through 'Local Networks>Entire Network>Microsoft Windows Network>Mshome and there they are! All very simple.

    I spent an hour on the Msoft pages last night, trying to fix this problem, but got nowhere. What am I missing? What is the easiest way to fix this? I just need to transfer some files from the XP desktop to the Vista laptop...shouldn't be that hard.

    Thanks!
  2. Blind Dragon

    Blind Dragon TechSpot Evangelist Posts: 4,048

  3. johnhenry

    johnhenry Newcomer, in training Topic Starter Posts: 92

    Thanks, that's the page I spent an hour with. Nothing on that page (that I could find) allowed me to share files with the XP machine. Any other ideas?
  4. Blind Dragon

    Blind Dragon TechSpot Evangelist Posts: 4,048

    This is what I took from there

    Change your network location type to private, network discovery is automatically enabled in the Sharing and Discovery section of the Network and Sharing Center window (from Vista computer obviously) The following additional file and printer sharing options must be manually enabled:

    File sharing -> In the Sharing and Discovery section of the Network and Sharing Center window, click the down arrow next to File sharing. Within the File sharing settings, click Turn on file sharing, and then click Apply.

    Public folder sharing -> Back to the Sharing and Discovery section of the Network and Sharing Center window, click the down arrow next to Public folder sharing. Click Turn on sharing so anyone with network access can open, change, and create files. Click Apply.

    Password protected sharing -> In the Sharing and Discovery section of the Network and Sharing Center window, click the down arrow next to Password protected sharing. Within the Password protected sharing settings, click Turn on password protected sharing, and then click Apply.




    Click Start, and then click Computer.


    In the Computer window, navigate to the folder containing the folder that you want to share.


    Right-click the folder that you want to share, and then click Share. The File Sharing window is displayed.


    If you have password protected sharing enabled, use the File Sharing window to select which users can access the shared folder and their permission level. To allow all users, select Everyone in the list of users. By default, the permission level for a selected user is Reader. Users cannot change files or create new files in the share. To allow a user to change files or folders or create new files or folders, select Co-owner as the permission level. Figure 5 shows an example of configuring users and permission levels in the File Sharing window.

    If you have password protected sharing disabled, use the File Sharing window to select the Guest or Everyone account. This is equivalent to simple file sharing in Windows XP.


    When complete, click Share, and then click Done.
  5. johnhenry

    johnhenry Newcomer, in training Topic Starter Posts: 92

    Thanks BD, I'll give that a try later on when my patience returns.
  6. Blind Dragon

    Blind Dragon TechSpot Evangelist Posts: 4,048

    For network discovery of computers running Windows XP and for file and printer sharing for both Windows Vista and Windows XP, you must allow the following incoming traffic:

    *

    UDP 137
    *

    UDP 138
    *

    TCP 139
    *

    TCP 445
  7. johnhenry

    johnhenry Newcomer, in training Topic Starter Posts: 92

    Thanks, I have the 'File and Printer Sharing' exception noted in the firewall settings. Should that be enough?
  8. Blind Dragon

    Blind Dragon TechSpot Evangelist Posts: 4,048

    are you using 3rd party firewall? which one? on both machines?
  9. johnhenry

    johnhenry Newcomer, in training Topic Starter Posts: 92

    No, not 3rd party. Just using the Windows firewall on both machines.
  10. Blind Dragon

    Blind Dragon TechSpot Evangelist Posts: 4,048

    Removed so that people don't follow this step
  11. johnhenry

    johnhenry Newcomer, in training Topic Starter Posts: 92

    I'm inclined to think this is not a port/router problem, because my XP laptop machine can share files just as it is now. This is a problem with configuring Vista to do what XP seems to do automatically.
  12. Blind Dragon

    Blind Dragon TechSpot Evangelist Posts: 4,048

    I'm inclined to think your computers are not in the same workgroup

    In Windows XP your workgroup is called MSHOME. In Vista, the default is WORKGROUP.

    If you want to view and edit the computer details on each PC to rename your workgroup, you can access this from the main "Vista Welcome Center" screen by choosing the first option "View Computer Details" and selecting "Show More". This will quickly bring up the Computer Name tab. Here you want to name your PC (this is what it will show up as on the network) and also change your workgroup name. You will need to use the same Workgroup name on each PC that you want to enable file sharing with.

    If you already turned it off like I have then the "Computer Name" tab is available from "Control Panel" ->Choose "System and Maintenance"-> choose "System"-> select the "Change Settings" button -> choose "Computer Name" tab.

    Once you have successfully changed your Workgroup name on all PCs, you can then access a network map from within Vista's Network & Sharing Center. Click Start -> choose "Network" -> "Network & Sharing Center"-> "View Full Map" to see all the systems and devices on your network.

    If this sticks check the Windows XP machine that you have the Link Layer Topology Discovery (LLTD) protocol installed on the machine. You can download the Link Layer Topology Discovery Responder from the Microsoft website
  13. johnhenry

    johnhenry Newcomer, in training Topic Starter Posts: 92

    Thanks!

    I've followed this "Once you have successfully changed your Workgroup name on all PCs, you can then access a network map from within Vista's Network & Sharing Center. Click Start -> choose "Network" -> "Network & Sharing Center"-> "View Full Map" to see all the systems and devices on your network."

    I can now see the Desktop in this map. But I can't click on it, and still cannot seem to access it anywhere. Where do I go to get on it?
     
  14. johnhenry

    johnhenry Newcomer, in training Topic Starter Posts: 92

    :mad: I can't believe what a PITA this is!!

    I just followed the link BD kindly gave to the letter, and nowhere does the stupid Vista machine show the XP desktop. Vista is incapable of seeing the XP desktop. Period. I've tried all the options BOTH WAYS in the wonderfully convoluted 'Network and Sharing Center.' Nada, zip...

    Meanwhile, my old XP laptop took all of three secods to find it and begin sharing files. What's going on here? Is this considered an improvement for Vista? I've been a loyal Windows guy for years, and am just now, for the very first time, feeling what those Apple commercials are all about.

    This is not a criticism of BD's greatly appreciated advice and help!! I'm still here, and still in need of help, so please continue! I just needed to get that off my chest.

    BTW, I don't need any encryption, any password protection, or any user restrictions on this silly network. We are in the middle of nowhere, there are no security threats here. I just want the Vista laptop to be able to take files off the XP desktop. My god does that ever sound simple.

    Thank you for your understanding.
  15. Blind Dragon

    Blind Dragon TechSpot Evangelist Posts: 4,048

    From here they may one extra step and it depends on whether you used vista upgrade or did vista come on this computer
  16. johnhenry

    johnhenry Newcomer, in training Topic Starter Posts: 92

    It came on the computer. It's a Sony Vaio, so Vista came pre-installed.
  17. Blind Dragon

    Blind Dragon TechSpot Evangelist Posts: 4,048

    AT this point I'll just verify -> both computers can go online and both have dynamic IP (Auto find IP/Auto find DNS) enabled- if so finish up below

    Back to Network & Sharing Center -> "Customize Network Settings" -> Public or Private Location. SELECT Private

    Network Sharing & Discovery -> make sure enabled
  18. johnhenry

    johnhenry Newcomer, in training Topic Starter Posts: 92

    "both computers can go online and both have dynamic IP (Auto find IP/Auto find DNS) enabled if so finish up below" Yes, correct.

    "Back to Network & Sharing Center -> "Customize Network Settings" -> Public or Private Location. SELECT Private" Yes, it has been on Private.

    And (currently) all options under "Network Sharing & Discovery" are ON.

    Thanks!
  19. Blind Dragon

    Blind Dragon TechSpot Evangelist Posts: 4,048

    k, go back to "Network & Sharing Center"-> "View Full Map"

    Look at the bottom of the screen does it show some devices that cannot be placed on the map. You should still be able to access the devices - but apparently some PCs or devices may not show in the map view due to "support is not currently available for the required protocols."
  20. johnhenry

    johnhenry Newcomer, in training Topic Starter Posts: 92

    No, all devices show in the map. The desktop is there in the map. I just cannot access it anywhere from Vista.

    I need to take a break now before this gives me an ulcer. Thanks for your help thus far Blind Dragon. I'll check back in a couple of hours.
  21. Blind Dragon

    Blind Dragon TechSpot Evangelist Posts: 4,048

    K, i gotta go anyways. Here is one last thing that just came to mind

    You need to have a user account for the XP machine on the Vista machine and the Vista machine on the XP machine.

    Add a user on each machine for the other one.

    Start -> Control Panel -> 'User Accounts and Family Safety'.

    The first selection in User Accounts and Family Safety is Add or Remove User Accounts
  22. johnhenry

    johnhenry Newcomer, in training Topic Starter Posts: 92

    Thanks again BD, but I don't think that is the issue here. My XP laptop does not have any extra user accounts for the desktop, nor did I add any to the desktop for the XP laptop. Yet they share files without a problem.

    Any other ideas? Anyone?

    Thanks--
  23. Blind Dragon

    Blind Dragon TechSpot Evangelist Posts: 4,048

    k, sorry I couldn't get you up and running

    I found this interesting on the Microsoft site.

    If the shared folder is on a computer running Windows Vista that has network discovery enabled, it should appear in the Network window quickly. If the computer containing the shared folder is on a computer running Windows XP, it might take up to 15 minutes for the computer to appear in the Network window.
  24. johnhenry

    johnhenry Newcomer, in training Topic Starter Posts: 92

    Thanks again BD.

    Is there any other information I can offer you guys? I feel I must be missing something small and obvious. Please help me out if you can; I really need to get this fixed ASAP, tonight if possible.

    Many Thanks.
  25. johnhenry

    johnhenry Newcomer, in training Topic Starter Posts: 92

    Can anyone help?
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.