Vista PC randomly disconnecting from modem, needs reboot

By bigdara
Jan 23, 2008
  1. Hi,
    I am having a really annoying problem with my internet connection.

    Randomly, but it seems after quite a few hours, I loose all connection out of my PC. No internet, email etc. I cannot even ping my modem (connected via network, cat5). Repairing doesn't work and I have to reboot to get the connection back.
    Is there anything that I can do to stop this or at least start trying to hunt the problem down.
    I have Vista home premium, windows live mail, zone alarms, avg anti virus, skype and DAP installed (and more but I'm thinking these my be the main ones that could affect problem).
    Any help would be great
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    Are you using an on-board NIC (network connection on the motherboard) or a PCI NIC? (a network card installed into a motherboard slot)

    Remove Zone Alarm and see if the problem stops
  3. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    disable skype and update the firmware in the modem (router) and NIC drivers.
  4. bigdara

    bigdara TS Rookie Topic Starter

    Hi, sorry for the delay in replying but I was hoping that updating the drivers would sort out the poblem, but alas no. The pc is a laptop so the nic is on the motherboard. I have turned off zone alarm but that didn't fix the problem. I use skype a lot and would have to have to turn it on again before I would possibly see the internet drop out. Do you really think skpye could do it? Any other ideas?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...