visual artefacts on radeon 9800 pro

By dragonet88
Nov 5, 2005
  1. i just got my ATi 9800 pro installed today along with the latest driver. the computer started with no problem, but when i try to play games like need for speed undergound 2 it give me flashing texture and image even though the game is still playable. so does anyone know what is the problem?

    Attached Files:

  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    download the latest game patch from the maker's website. download the latest version of catalyst for your card (via the ati website). apply both, restart the machine, and see if the problem persists.
  3. SheHateMe

    SheHateMe TS Rookie Posts: 27

    Try reseating the video card, also usually when upgrading a major part of the computer, you should reformat. So if all else fails, reformat is in order. But try what he said first, then reseat your video card.
  4. dragonet88

    dragonet88 TS Rookie Topic Starter

    i have the latest catalyst driver (downloaded from installed and the lastest game patch though i don't think that will do any good since the problem seem to occur in all games i've tried (nfsu2, age of empire 3, far cry). i don't think there is problem with the power supply nor the temperature of the the card.
    i'm not sure how how to reseat the card, but i've already reformatted the system once but the problem is still there.
  5. SheHateMe

    SheHateMe TS Rookie Posts: 27

    All you do to reseat, is pull it out of the AGP slot, and pop her back in. Make sure it goes in all the way, and is in there firmly, but don't force it in.
  6. AtK SpAdE

    AtK SpAdE TechSpot Chancellor Posts: 1,495

    I would not rule out a PSU. What wattage and brand do you have?

    Reseating a card simple means to take it out of the slot, and put it back in. This can help, if you have a bad connection.

    How new is the card..If you have tried different drivers, PSU is good as wells as is possible you may have a bad card.
  7. dragonet88

    dragonet88 TS Rookie Topic Starter

    i guess i am just gonna take the card to the ATI Headquarters located a few blocks away and get it fixed or perhaps replace it

    has anyone acutally done this before, do i need to bring anything else except the card (the card has a sticke on its back)
  8. hangintite68

    hangintite68 TS Rookie Posts: 18

    if you overclocked it, and didn't do it properly, it will give you that, also you can try those are specailly tweaked drivers for ATI and Nvidia!
  9. dragonet88

    dragonet88 TS Rookie Topic Starter

    this card hasn't been overclocked before, and the omega driver has no effect to the problem
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...