VNC can't connect (timeout)

By DjKraid
Nov 10, 2010
Post New Reply
  1. Hi!

    I have these 2 computers connected together with hamachi so they believe they are in a LAN...anyhow...I have VNC Server 4.1.3 on one and VNC Viewer 4.1.3 on the other and when I try to connect it always times out, it doesn't even ask for the pw.

    I have allowed vnc trough both computers firewall and same goes for hamachi.

    First when I tried to ping (with cmd) the server it also timed out but then I enabled the File and Printer sharing setting and now the pinging works and file sharing but not vnc...why? -any ideas? -what to do next?

    EDIT

    P.S. I have disabled and stopped the Fast user switch on both computers
  2. DjKraid

    DjKraid TechSpot Maniac Topic Starter Posts: 611   +14

    ...it can't even connect (with the "LAN IP 192.168...) when the computers are connected to each other via a switch (ZyXEL ES-108A)...

    any ideas?
  3. DjKraid

    DjKraid TechSpot Maniac Topic Starter Posts: 611   +14

    Now it works!

    First I added the "winvnc4.exe" (on the server) as an exception to the firewall and then "vncviewer.exe" (on the "controlling machine") but that wasn't enough. After a while I just tested a theory and added an exception only for the port that VNC uses and that was it :)
  4. jobeard

    jobeard TS Ambassador Posts: 13,275   +280

    well done - - just look what you've learned from this exercise :)
  5. DjKraid

    DjKraid TechSpot Maniac Topic Starter Posts: 611   +14

    ...yeah...last time when I used VNC I only installed VNC and hamachi and then it just worked...but not now...


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.