TechSpot

Weird problem with taskbar

By Imfatyourefat
May 23, 2009
  1. My taskbar seems to be covering up the bottom of programs when they are maximized. It also covers up the bottom of the desktop and icons laying at the bottom of the screen.

    Normally the taskbar should end before the desktop or a maximized window begins.

    I've tried checking to keep the taskbar on top of other windows in the properties menu and when I apply auto hide on the taskbar a maximized window is not resized but rather the bottom is just reveled.

    How do I undo????

    Thanks
     
  2. red1776

    red1776 Omnipotent Ruler of the Universe Posts: 5,219   +157

    im not sure i understand what its doing, but have you tried unchecking 'lock the taskbar'?
     
  3. Imfatyourefat

    Imfatyourefat TS Rookie Topic Starter

    yes I've tried to lock and unlock the taskbar.

    to try and better describe it. Say that firefox is open and it is maximized on the screen. Normally you would see the bottom of the firefox window and then the taskbar below that. However, for me the grey status bar along the bottom (the place where is says "done" or gives you info on what is being loaded) is covered by my taskbar.

    I had the thought that this may be a bug related to VLC media player regarding some function of the full screen mode but thats just a shot in the dark.

    hope that helps
     
  4. gbhall

    gbhall TechSpot Chancellor Posts: 2,425   +77

    I hope you are talking about XP. For Vista/win7 all bets are off.

    Right-click the taskbar and select 'properties'. Make sure Auto-hide the taskbar' is checked. You say you have done this, but the behaviour of the taskbar is simply to slide out of sight when the mouse does not hover over it. The way it behaves when the desktop is showing a maximised window or not is as follows.

    If not maximised, the taskbar is not visible, but pops up when the mouse moves into the area where the taskbar will appear.
    If a maximised window is present, the mouse will not cause the taskbar to pop up, you have to use the 'windows' key on the keyboard.

    If in addition to auto-hide, you also have set 'keep the taskbar on top of other windows', then the behaviour changes only for full-screen desktop. It seems to cause the taskbar to pop up on mouse getting near in the same way as it does for a NONE-maximised desktop.

    In ALL cases, a maximised window on a desktop is supposed to be just that - it always should fill the desktop, and if the taskbar covers part of it, it is because it is not dropping out of sight when it should.

    If your taskbar does not behave in this fashion, it needs to be reset. Let us know. For your purposes, you should have 'auto' on and 'on top' off.
     
  5. Imfatyourefat

    Imfatyourefat TS Rookie Topic Starter

    sorry this is hard to describe. I don't use auto hide and don't want to. The problem exists when auto hide is not checked.

    I would post a screen shot but apparently I have to have more post before I'm allowed to do that
     
  6. Imfatyourefat

    Imfatyourefat TS Rookie Topic Starter

    posting to show screen shots...
     
  7. Imfatyourefat

    Imfatyourefat TS Rookie Topic Starter

    posting to show screen shot...
     
  8. Imfatyourefat

    Imfatyourefat TS Rookie Topic Starter

    here is a screen shot:
    [​IMG]
     
  9. gbhall

    gbhall TechSpot Chancellor Posts: 2,425   +77

    Do you accept that a maximised window should fill all the screen? As far as I have ever seen, this is always the case. What your screenshot shows is to me what happens with autohide off AND keep ontop ON.

    With keep ontop OFF, a maximised desktop covers the taskbar, but the taskbar is otherwise always visible if auto-hide is OFF.
     
  10. deanlaing12

    deanlaing12 TS Enthusiast Posts: 127

    try pressing f11 when ur on the internet exploarer, dow that help?

    Right clikc on my computer and click propertys

    advanced

    performance

    then what to do is click on "let windows choose what is best for my computer"

    then restart your computer

    then put the settings back

    then it might be fixed.


    Another methos might be to change the resolution and then change it back?

    if non of them work then you have an option turned on to do this feature.




    From the internet exploarer right clikc the task bar and click on tile windos horozontaly and then maximise the windows

    do the same but for vertiaclly




    (i don't no what wud fix this but heres a good list to try,
     
  11. Imfatyourefat

    Imfatyourefat TS Rookie Topic Starter

    I still don't understand what was going on but letting windows choose configurations for me seems to have worked.

    Thank you so much for the help.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...