Weird problems in Counter Strike using 9800 pro

By uzairzaidi
Jan 10, 2005
  1. Hi guys Im really bummed out about this problem that I have been having recently and its starting to frustrate me. Hopefully you guys can help me out cuz I have no one else to turn to.

    Alright. I play Counter Strike quite often I recently stopped playing for around 2 months and decided to install it again to play. My windows is updated and I have the latest drivers for my Ati Radeon 128MB 9800Pro. I have a 3.0GhzE Prescott PC with 512MB ram. I used to get constant 100FPS no matter what in CS 1.6 even in 4-5 smoke grenades. When I installed it again it acts weird on me. My performance stays solid for the first round then all of a sudden my FPS drops to 25-40 fps and stays there. I have done a virus scan and have even use Adaware and Spyboy Seach & Destroy to check if it is any other 3rd party software/file affecting my performance, but there isnt any. I dont know how to use BIOS or upgrade my motherboard and what not settings and only upgrade my Radeon drivers from the Ati website. I am currently running their latest 4.12 version and am thinking if that could be the problem.

    Please help me out

  2. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,377

    Try older drivers. I had alot of problems with Catalyst 4.11 and had to go back to 4.10.
  3. uzairzaidi

    uzairzaidi TS Rookie Topic Starter

    ty bro ill check it out
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...