TechSpot

Western Digital MyBook external HD malfunctioning

By pingpongmury
Nov 28, 2009
  1. I recently purchased a 1 TB Western Digital MyBook external hard drive. The device turns on just fine, displaying a light blue oval shape on the front of it. Although when i try to move files onto the drive, the amount of free space goes down, but the files do not show up in the drive. There are no sub-folders only one central folder where i tried to move the files. I have "show hidden files and folders" on so it's not being hidden. Because it was the first time i've used it, I decided to try to format it, but after I set the options to default and clicked start. It asked me if i was sure i wanted to, clicked yes, then it said "Windows was unable to format drive"

    If anyone has an idea on how to fix this issue it would be much appreciated. If you want some further clarification on what is going on, I have no problem doing so.

    Thank you,
     
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    1) If you just bought it, your best resolution might be to simply return/exchange for another one

    2) For general reference, See Troubleshoot: Windows Won't Recognize Your USB Hard Drive and note the first couple steps. Try
    > Running Windows Update
    > Running the DriveCleanup tool

    3) Also, do you have the same problem with a different computer? You can also test it on your computer under Knoppix (to see if it's a Windows issue or not) See How to recover your folders/files when Windows won’t boot for how to create a bootable Knoppix CD. Then boot up and test it
     
  3. pingpongmury

    pingpongmury TS Booster Topic Starter Posts: 94

    I'll try it on another computer when I get a chance.

    Thank You, for your help
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...