Where do I get SM Bus and Simple Comu. Controllers?

By ynotbme
Dec 22, 2013
Post New Reply
  1. Drivers right? How do I determine which and where to get the drivers. I have a dell inspiration 531 Desktop running XP Home. I reformatted the hard drive...I know big mistake. Did not back up drivers or get a list of hardware. But I do have a service tag. JBGP3G1. I would also love a network controller... you know to get online! I thought XP had generic versions to get you started with. HELP!
  2. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

  3. ynotbme

    ynotbme Newcomer, in training Topic Starter Posts: 26

    Thanks, tried that already. I have internet access through my laptop. But, not through the Dell Desktop. No network controller...no internet! I have to at least load up the simple communication and network controllers to get online. Any ideas?
  4. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

  5. ynotbme

    ynotbme Newcomer, in training Topic Starter Posts: 26

    Hi, I went back to Dell and tried to download the network controller. It did not do anything. It asked which program I wanted to open with. I went to site downloaded onto usb flash drive. Tried to open program on my newly reinstalled XP Home. NO program to open with. Next I will try to download 7zip. Hopefully that will work...if I open it first. I will let you know. Thanks!
  6. ynotbme

    ynotbme Newcomer, in training Topic Starter Posts: 26

    Wow. Am I in the right spot? It can not be that difficult to get help finding a XP Network controller diver download for the A Dell inspiration 531. The download will not work at Dell. Maybe I am doing something wrong. But I have fixed about 10 dells. I even found sound drives from other systems for xp pro os changes. But this is frustrating and only one person has been kind enough to at least reply. Dell is not the answer...unless I am some how downloading and coping wrong the driver download. Some else have any ideas or just some generic driver that will get me online? Once online...the original OS is XP Home and I have a service tag. All I did was reinstall the OS. with the factory Dell OS disc. I wish I would not have reformatted. In small print the disc does say OS only no drivers included. HELP!!!!
  7. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    Understand that everyone here volunteers their time. It's a holiday week here in the States. So it will likely be slow around here for a bit longer....

    That said.. I downloaded the Dell driver myself. I get a file named R183381.exe. It's a self-extracting file. In my case, when I run it, it unpacks the files then starts the nVidia driver install.

    In any event, I created a zip file version for you click HERE. Unzip to extract the files and run then double click the setup.exe to run it
    JC713 likes this.
  8. JC713

    JC713 TechSpot Evangelist Posts: 6,797   +882

    After clean-installing Windows 7 I got missing drivers for the SM bus and a few others. I am not worrying since my system is stable, and Windows was not able to find a driver. I wouldnt worry unless you run into issues. But, if you are reluctant to fix it, @LookinAround seems to be getting somewhere!
  9. ynotbme

    ynotbme Newcomer, in training Topic Starter Posts: 26

    Hi I am just frustrated. I tried to use the zip file. I am running Windows 7 (64) on my computer. I am using Nero 11 and burning a data disc. I have tried saving to disc, saving to desktop in a file to disc. I have used a usb flash and saved both ways to that. R183381_exe does not open or run on either my computer or the XP computer. Neither does the zip. The only thing I got to run on both machines was a download of Everest. It actually had the Icon of a Zip file. And unpacked and installed perfect on the XP. So I believe this is a formatting or tag error. Why is the Everest Zip recognized but not your zip or the file from dell?
  10. ynotbme

    ynotbme Newcomer, in training Topic Starter Posts: 26

    I just went and renamed the files...changed the _ to a . My computer recognized the files! Ha! I am going to run down stairs and try to rename the files on the XP computer. Could it be that simple? Thanks for all your help. I will let you know if this works. Either way you have been awesome! Thanks, again! Ynotbme
  11. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    Good catch! (y) Though it's curious why the character in the filename was changed?? :confused: :confused: Maybe by your antivirus?? In any case, hope it now works

    @JC713
    just fyi, should it be helpful in the future.. SM Bus is a data controller for low bandwidth devices. Typically (at least based on what I've seen) if the chipset drivers don't resolve it, it usually means it's part of a 3rd party device on your machine (perhaps a card reader)
    JC713 likes this.
     
  12. ynotbme

    ynotbme Newcomer, in training Topic Starter Posts: 26

    Wow. As usual something weird and simple! It worked! Hopefully, it goes smooth now. Thanks LookinAround. I will be back when I run into more trouble. Bye the way Happy Holidays! Thanks again, ynotbme
  13. JC713

    JC713 TechSpot Evangelist Posts: 6,797   +882

    Ah! Most likely! I installed the chipset drivers so it must be the card reader! Thanks!!!!


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.