TechSpot

Wifi Capability being turned off

By Julie127
May 25, 2014
Post New Reply
  1. Forgive me for not knowing the proper terms, but am newer to the Wifi game - have only had it since February.

    Our Gateway Laptop has always recognized our Wifi signal until a week ago. Now whenever it goes to sleep or is shut off it does not recognize that we have internet. Instead of the 5 bar icon showing; it has a red x. The only way I can get it to connect is to reboot. I have done a system refresh and also tried to update the driver (Realtek RTL8188CE) but it says I have the most up-to-date version.

    This is extremely frustrating! Does anyone have any ideas?
     
  2. cliffordcooley

    cliffordcooley TechSpot Paladin Posts: 6,399   +1,591

    "Troubleshoot problems" (right click the network icon) can fix the majority of issues without needing a reboot. It will turn off the adapter and re-initialize the drivers.
    • On portable devices the wireless adapter can be manually turned off for most devices. It is usually a Fn key that is used to turn wireless off.
    • Wireless can be disabled and enabled, within the list of network connections (Control Panel > Network and Internet > Network Connections).
    I know it is frustrating and I don't have a proper solution for you. Especially when you say you have updated your drivers. But the above may help in keeping you from having to completely restart your machine.

    One thought does come to mind though. That is checking to see if the wireless is set to turn off when the PC goes in sleep mode. Keeping wireless active could keep it from bugging out.
    • Control Panel > Hardware and Sound > Power Options > Change Plan Settings
    • Change advanced power settings
    • Wireless Adapter settings > Power Savings Mode > Setting:
    • There is a choice between (Performance, Low, Med, and Max)
    My desktop never sleeps and wireless is set to performance. So I have no experience with the setting, I just know it is there.
     
  3. jobeard

    jobeard TS Ambassador Posts: 13,515   +336

    That's a problem in the WiFi driver. You should NOT have problems sleeping or hibernating the laptop.

    First, get a wired connection so you can access the Internet, then
    Use the Device Mgr, find the WiFi device and Update the driver
     
  4. Julie127

    Julie127 TS Rookie Topic Starter

    Thanks to both of you. I tried everything in the first post and nothing. I have tried to update the driver again and it says it is up to date. Also, I do not have access to a wired connection.

    I have found that if I go into Control Panel - Network and Internet - Network Connections & click on the Wifi and click Diagnose this Connection, it will reset without having to reboot. It's a quicker work-around, but still don't know why... When it is done it says, "Trouble with wireless adapter or access point - Fixed", but it is not since it has happened twice since then. :-(
     
  5. Frozwire

    Frozwire TS Member Posts: 63

    You can try to check Computer Management>Device Manager>Network Adapters>WiFi Adapter(Realtek RTL8188CE)> (Right Click> Properties) then under Power Management Tab un tick the box Allow the computer to turn off this device to save power.
     
  6. jobeard

    jobeard TS Ambassador Posts: 13,515   +336

    That is not related the the symptom and logically might make it worse,
    but having said that - - Yea, I have that setting too.
     
  7. Julie127

    Julie127 TS Rookie Topic Starter

    It is now not as frequent, but probably every third time instead of every time. Still driving me crazy though! LOL
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.