Wifi connected but no internet

By dertyDos
Jun 27, 2009
  1. I need help big time.... i have a Toshiba Satellite m105-s3041. and all of a sudden the internet stopped working.. i used to use IE then it wouldnt let me get on. so i got Mozilla then after a while of using that it stopped... for a bit when i started my laptop a pop up saying something about rundll.... but i would still be able to use the internet... then one day the wifi icon on the bottom right hand corner had a triangle with an exclamation point in it.... then i got it to connect but now it says it has an Excellent connection but i cannot get on the internet.. i check the status and its sending some packets but its not recieving any..... so i tried ipconfig/release and /renew that didnt work.... but i think the problem has something to do with the fact that the IP address on the PC that the modem and everything is connected to it like 192.168.*.** & the subnet is * = not sure excatly at the moment but if needed i can get it) and on my laptop its 169.254.*.* and its subnet is* I REALLY need to get this working.. so anybody who can help it would be MUCH appreciated... thanks!!!
  2. snowchick7669

    snowchick7669 TS Maniac Posts: 660

    Have you configured it to to 'automatically detect' setting in the wireless IP config.

    I'd considering running through the 8 steps here to see if that uncovers anything
  3. ChrisDown

    ChrisDown TS Rookie Posts: 125

    Occasionally the IP will go to a 169.254 range if you specify an already assigned address, or you specify an incorrect address. The triangle would also suggest that this is the case -- it sounds like you have an IP address conflict, not malware.

    Try changing your IP from 192.168.*.* to have the last number as a different one (up to 255). Otherwise, do what snowchick said and set it to automatically detect the IP and DNS settings.

    Thanks. :)
  4. ChrisDown

    ChrisDown TS Rookie Posts: 125

    I do hope that wasn't serious.
  5. dertyDos

    dertyDos TS Rookie Topic Starter

    i tried setting the IP. that didnt work either.... i had a friend tell me to turn off the DHCP on the main computer.... so i did i turned it off, then BAM right away i was able to log on the internet.... i thought that everything was straight. but then the next morning my dad was unable to get on the internet on his PC (the one actually connected to the MODEM) so i turned it back on then it went back to SH!T!!!! what the F**K is the DAMN PROBLEM im getting PISSED!!! please help!!
  6. dertyDos

    dertyDos TS Rookie Topic Starter


    PLEASE HELP...... IT would be greatly appreciated!!!!!!!!!!! THANKS!!!!!!
  7. Rick

    Rick TechSpot Staff Posts: 4,573   +65

    This is an automatic private IP address. An IP is a unique number used to identify your computer on your network. Your router hands out IPs as a DHCP server.

    That 169 IP address tells me that your computer cannot connect to the DHCP server (your router). You *can* connect to the wireless though, so something is blocking network traffic between your computer and your router. The reason it cannot lease an IP could be a few things:
    1. A problem with your wireless network configuration, such as MAC filtering, incorrect WEP/WPA key etc..
    2. Your winsock is damaged (settings that allow Windows to understand how to use your network)
    3. A problem with or misconfiguration of security software, such as a firewall that is blocking ICMP (or perhaps all) network traffic.
    Ensure you are connected the *correct* wireless network. You may want to delete and recreate the wireless profile you have setup in the utility you use to connect to your wireless network... make sure your password and information is correct. If you have reason to believe that changes may have been made to your wireless router such as MAC filtering, then please check.

    Once you've done this, disable your firewall (if you even have one) and reconnect to your wireless network.

    If it still doesn't work, try resetting your winsock by:
    1. Start > Run > cmd.exe
    2. Press [Enter]
    3. Type: netsh winsock reset
    4. Restart your computer

    Does it work now? No? Uninstall your firewall and reset your winsock again.

    Still doesn't work? I'd hate to be you. :-(
  8. Rick

    Rick TechSpot Staff Posts: 4,573   +65

    I know it is a lot of typing, but can you give us an ipconfig /all for each of your computers?
    • Start > Run > cmd.exe
    • [Enter]
    • Type: ipconfig /all
    • [Enter]

    You can also type: ipconfig /all >C:\ipconfig.txt
    That will place all of the ipconfig mumbo jumbo into a text file named "ipconfig.txt" on your main hard drive (C:). Then, just copy the output.txt file to a thumb drive or something so you can upload it here.

    It'll save you from hand typing all that stuff. You could also snap a picture of the terminal screen, as long as it is readable.
  9. subcan

    subcan TS Rookie Posts: 51

    connect modem to wireless router first


    From this it sounds like the modem connects to your dads computer and then from there to a wireless router?

    It would work much better to the modem connect to the wireless router... have the wireless router assign DHCP and then have your dads computer connected to a Ethernet port from the back of the wireless router.

    When desktop computers assign DHCP problems arise. This is a confusing situation that may not need to be.

    Hope this helps??

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...