TechSpot

Win 2k does not recognize my cd drives

By Bishop
Jan 6, 2006
  1. Have a win2k machine. When i go into MY Computer or Disk Management the cd burner (set to slave) and the cd rom (set to master) are not shown. if i go into device manager the drives are shown under DVD/CD Drives. they are shown in the bios and can boot off them. its just the OS does not see them. Also, i changed the transfer mode on the second ide channel in device manager, rebooted and same result. OS does not see them. I even changed the cd drives and same thing, os does not see it. need help with this one. thanks.
     
  2. Bishop

    Bishop TS Rookie Topic Starter Posts: 36

    Ok, so i did some searching around and found the solution to my question.

    Adaptec knows what the Hibernate problem is with the 4.02 update. It
    > > is a
    > > file called "cdralw2k.sys". When 4.02 is installed it adds filters to
    > > the
    > > registry so that this file is used instead of "cdrom. sys" which comes
    > > with W2K. When the Adaptec software is uninstalled the registry is
    > > not reverted to use "cdrom. sys" and
    > > hence the Hibernate problem continues and you lose access to your
    > > CDROM Drives. You have to edit the registry to stop the Adaptec driver
    > > after uninstall. The critical keys that the software leaves behind
    > > after being uninstalled are in:

    HKLM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFCl-087002BEl0318}

    - Hide quoted text -
    - Show quoted text -

    > > In this section you will find two keys called "UpperFilters" &
    > > "LowerFilters". You will need to delete both of these keys and reboot
    > > to
    > > restore win2K to the default CD driver. You should also search for
    > > other
    > > keys containing "cdralw2k" and "cdr4w2K". If you find any delete the
    > > keys and then delete these two files AFTER the reboot. Note you-cannot
    > > delete the references to these
    > > in "ENUM" as they are generated from the class driver, but they will
    > > not be
    > > there after the reboot.

    credit goes to Brian Hiers: that post was posted Aug 29 2000, 2:00 am
    thanks Brian.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.