win 98 to win xp upgrade now cant boot hdd

By maypo52
Nov 21, 2005
  1. Hello All,

    I am upgrading a Compaq Presario 5000us (amd 750mhz, 128mb ram, 30gb hdd).

    I booted the xp install disk, ran setup, files were copied to the hdd, then it tries to reboot to continue installation and it just sits there.

    I read another thread here in this forum (I think) which said to copy the boot.ini, ntldr and files from a good system onto a floppy and try to boot the system with problem.

    That worked.

    I was able to boot the system and complete the installation process, but the system will not boot without the floppy. I even copied the boot.ini, ntldr and from the floppy to the system disk and it still wont boot the hdd. But as long as I boot with the floppy, it works fine.

    Any suggestions will be greatly appreciated.


  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Boot into recovery console, run fixmbr, fixboot.
  3. maypo52

    maypo52 TS Rookie Topic Starter

    Thanks for your reply.
    I tried the fixmbr and fixboot but they did not fix the problem. I had to do an fdisk and then reinstall xp. Oh well at least it's up now.

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...