Win Vista RC1 & nVidia 96.33 Driver

By Captain828
Sep 4, 2006
  1. I'm having a difficult time w/ the these damn drivers. They just don't seem to see my GPU (ASUS EN6600 TD256 AGP8x). They install correctly, but in the control panel (nVidia's), my video card is nowhere.

    Is there a way to make these drivers work well, or are there any other (Vista) drivers that are working?

    I'm runing Windows Vista RC1 build 5600.

    If someone could help...
  2. sellmesanity

    sellmesanity TS Rookie Posts: 162

    It is just the way the drivers are programmed...I really just think that vista and it's drivers need more time to mature. Everyone expects everything to go fine, but many cards are untested still with the drivers...thus this thing happening to you. Don't worry man, be patient, it will be sorted out in a couple weeks or months (most likely by nvidia themselves)
  3. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    any NVIDIA drivers made after 81.98 are unstable and in fact, aren't endorsed by microsoft - that is why they won't auto-download with windows updates.
  4. Captain828

    Captain828 TS Guru Topic Starter Posts: 287   +10

    thx for your support guys; anyways, I was just trying Vista out to see what's w/ all the hype... and I have to say I am impressed to see such a solid OS (for an RC1, that is :rolleyes: ) and I am certain that Vista will be ready for January '07
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...