TechSpot

Windows Installer Issue

By P3ANUT
Aug 2, 2008
  1. Hi, well lately i been running into this issue.

    The Problem : I try to install nero, it unpacks etc.
    then all of a sudden it pops a message up
    Windows Installer :

    Code:
    Windows ® Installer. V 3.01.4001.5512 
    
    msiexec /Option <Required Parameter> [Optional Parameter]
    
    Install Options
    	</package | /i> <Product.msi>
    		Installs or configures a product
    	/a <Product.msi>
    		Administrative install - Installs a product on the network
    	/j<u|m> <Product.msi> [/t <Transform List>] [/g <Language ID>]
    		Advertises a product - m to all users, u to current user
    	</uninstall | /x> <Product.msi | ProductCode>
    		Uninstalls the product
    Display Options
    	/quiet
    		Quiet mode, no user interaction
    	/passive
    		Unattended mode - progress bar only
    	/q[n|b|r|f]
    		Sets user interface level
    		n - No UI
    		b - Basic UI
    		r - Reduced UI
    		f - Full UI (default)
    	/help
    		Help information
    Restart Options
    	/norestart
    		Do not restart after the installation is complete
    	/promptrestart
    		Prompts the user for restart if necessary
    	/forcerestart
    		Always restart the computer after installation
    Logging Options
    	/l[i|w|e|a|r|u|c|m|o|p|v|x|+|!|*] <LogFile>
    		i - Status messages
    		w - Nonfatal warnings
    		e - All error messages
    		a - Start up of actions
    		r - Action-specific records
    		u - User requests
    		c - Initial UI parameters
    		m - Out-of-memory or fatal exit information
    		o - Out-of-disk-space messages
    		p - Terminal properties
    		v - Verbose output
    		x - Extra debugging information
    		+ - Append to existing log file
    		! - Flush each line to the log
    		* - Log all information, except for v and x options
    	/log <LogFile>
    		Equivalent of /l* <LogFile>
    Update Options
    	/update <Update1.msp>[;Update2.msp]
    		Applies update(s)
    	/uninstall <PatchCodeGuid>[;Update2.msp] /package <Product.msi | ProductCode>
    		Remove update(s) for a product
    Repair Options
    	/f[p|e|c|m|s|o|d|a|u|v] <Product.msi | ProductCode>
    		Repairs a product
    		p - only if file is missing
    		o - if file is missing or an older version is installed (default)
    		e - if file is missing or an equal or older version is installed
    		d - if file is missing or a different version is installed
    		c - if file is missing or checksum does not match the calculated value
    		a - forces all files to be reinstalled
    		u - all required user-specific registry entries (default)
    		m - all required computer-specific registry entries (default)
    		s - all existing shortcuts (default)
    		v - runs from source and recaches local package
    Setting Public Properties
    	[PROPERTY=PropertyValue]
    
    Consult the Windows ® Installer SDK for additional documentation on the
    command line syntax.
    
    Copyright © Microsoft Corporation. All rights reserved.
    Portions of this software are based in part on the work of the Independent JPEG Group.
    This isn't the first time, i try to install Sony sound forge , Adobe Audition also ........
    So i try to upgrade my windows xp also but it give me this error also ...
    is there a way i can fix this ( do i need to preform a update or some thing )
    -Thanks P3anut
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    In WindowsXP
    Start--> Run--> C:\Windows\system\msiexec.exe /regsrv32

    Restart try again.

    Note: this error is most likely caused by a Virus or Malware present on your system

    Please update your Antivirus and do a full scan
    Also you may want to download Malwarebytes, update, run full scan, manually remove all found entries
     
  3. P3ANUT

    P3ANUT TS Rookie Topic Starter Posts: 30

    Thanks for the reply,
    i Restarted then i went to start>run>C:\Windows\system\msiexec.exe /regsrv32

    It give me a error :
    Windows cannot find (C:\Windows\system\msiexec.exe /regsrv32) make sure you typed the name correctly . etc .....

    Currently am bout to run scan's ill report back once done ,
    -Thank P3anut
     
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Doh!

    Try:
    C:\Windows\system32\msiexec.exe /regsrv32
     
  5. P3ANUT

    P3ANUT TS Rookie Topic Starter Posts: 30

    Lol ^^
    Thanks for help , i found out what it was... ( it let me install nero other programs now .... )
    but when i try this again
    C:\Windows\system32\msiexec.exe /regsrv32
    it said Windows Installer: Incorrect Function

    why does it say that for....??
     
  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

  7. SnapHook

    SnapHook TS Rookie

    I wish P3anut had said what the problem was.

    I am experiencing the same problem, have scanned for malware, disemboweled my firewall and AV, installed v4.5, and still get that dialog only with Installer 4.5 instead of 3.01 at the top. I also get the Incorrect Function error when trying the C:\Windows\system32\msiexec.exe /regsrv32 command.

    Any other thoughts?
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...