Windows Repair

By sat-pimp
Jun 18, 2007
Topic Status:
Not open for further replies.
  1. I recently had to do a repair on my system running Windows XP Pro. After the repair it ran thru the intro( asking me for users names and so forth). After a reboot the OS deleted all my user accounts and wont go to safe mode, so I can create new user accounts. It goes streight to the windows log in screen. The only account listed is the Administrator. I log in as Administrator, it will not let me do anything. It tells me i dont have administrator rights.
    Any out there seen this before?
    If so any help would B great.
    Thanks Pimp
  2. Mugsy

    Mugsy TechSpot Maniac Posts: 410

    This is a nasty one. Something similar happened to me recently with XP telling me "I didn't have permission" even though I had Administrative rights.

    For me, the problem occurred after I tried to restore the backup I made of my C: drive, to the new installation. XP tries its best, but the "permissions" settings on every folder get restored too, and THAT is where you get into trouble. I suspect Windows' Repair overwrote many of your key Windows folders "Documents and Settings" with folders different from what you once had.

    The "can't enter Safe Mode" sounds worrisome, but I suspect the "3 second delay" in Windows (where it waits for you to hit a key like F4 or F8) has been eliminated or reduced to zero so that it never sees the keypress. This can be checked easily enough. (Oops, bad advice here. Let me recheck this on using RegEdit). If that's not the case, something else is going on.

    In my case with all the problems, I had to reformat and reinstall Windows. Problems such as this are too complex and time consuming to fix by hand one at a time, when a simple clean install will fix everything quickly.

    Let us know what happens.
  3. Mugsy

    Mugsy TechSpot Maniac Posts: 410

    Hmm, after much research, I can't find anything on changing the length of the Boot Menu delay in XP. Funny, I thought I had seen that one.

    An alternative way to force yourself into Safe Mode:

    • Start msconfig
    • Click on "BOOT.INI"
    • Choose the option "/SAFEBOOT"
    • Click "OK"

    When you reboot, you'll start in Safe Mode. To be get back into normal mode, repeat the same procedure but uncheck "/SAFEBOOT".
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,419   +281

    To change the delay you need to edit your boot.ini or if you are scared of text: Right click on My Computer -> Properties -> Advanced Tab -> Startup and Recovery Settings Button -> Time to Display List of Operating Systems.
  5. Mugsy

    Mugsy TechSpot Maniac Posts: 410

    Boot.ini not used in XP.

    XP does not use the "boot.ini" file anymore. It's a zero byte file in XP.

    Changing the "OS Display" option above does not affect the time Windows waits for you to hit the F8 key, only the time until a default action is taken.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.