Windows Won't Recognize Hard Drives

By SageOfTheWabash
Mar 6, 2007
Topic Status:
Not open for further replies.
  1. Hello all, I was forced into an upgrade by a mobo failure. This evening I installed an "Asus P4S800D-X mobo, a Western Digital 500 gig hard drive, a Maxtor 250 gig hard drive both of them SATA. 4 gig of dual channel 184 pin PC 3200. When I enter bios the system seems to recognize the hard drives. However, when I try to install XP Windows says that I don't have any hard drives in the system.? What are some things that I can check or do to trouble shoot this glitch? Thanx
  2. beef_jerky4104

    beef_jerky4104 Banned Posts: 1,094

    When Windows is loading up it should say somewhere on the bottom of the screen (where it shows whats loading) Press F5 if you need a raid driver. OR something along on those lines. Then you press the key and put in the floppy that cmae with you Motherboard. It will probably say something like SATA Driver. Do that and you'll be able to use those drives.
  3. SageOfTheWabash

    SageOfTheWabash Newcomer, in training Topic Starter Posts: 58

    I remember having seen that prompt before. " Press F? if you need to install a third party raid driver ". The MOBO came with a CD not a floppy, but I'll bet it will contain the driver I need. This also begs the question, which type of raid should I choose? Thanx for the heads up
  4. robin_bga

    robin_bga Newcomer, in training Posts: 258

    does it give any options?if it does tell us what u see but u should put in mind that its asking u the driver that is compatible with the chip on your mobo.so if u have options related to your mobo,then choose those. R
  5. SageOfTheWabash

    SageOfTheWabash Newcomer, in training Topic Starter Posts: 58

    I was wrong. I do need a floppy. windows says insert diskette into drive A, Apparently it will accept nothing else.
  6. Tedster

    Tedster Techspot old timer..... Posts: 10,067   +13

    which is the reason never build a computer without floppies. Still required for BIOS and core updates.
  7. scott_ottawa

    scott_ottawa Newcomer, in training

    Sage

    Look in the BIOS and see if you can find a submenu that looks like "Serial ATA (SATA)".

    If you find this it may be set to Advanced Host Controller Interface (AHCI). Change it to

    • SATA Controller Mode Option: Compatibility

    Then install XP. After that get the necessary drivers for your m/b and chipset (maybe Intel.com has this).

    Once you've installed this driver (sometimes called the Matrix Storage Manager driver) go back into your BIOS and set the option back to AHCI

    • SATA Controller Mode Option: AHCI
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.